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Overview
Create a report when you need to print information and you want the flexibility to...

Related information
            Creating a report  
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Overview
As soon as you've entered information in your database, you can create a report.    Works asks you for the 
information and then creates the report for you.

Related information
            Lesson: Reporting  
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Creating a report
When you choose Create New Report from the View menu, Works displays the New Report box.    The title you type 
will appear on the first page of the report.    The fields you add determine the information and headings that will 
appear on every page of the report.

more...
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Creating a report, cont.
Next, Works displays the Report Statistics box.    If you want Works to print summary information for fields at the 
end of your report, choose the fields and the statistics you want Works to use.    Example:

more...
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Creating a report, cont.
If you want Works to add all the entries in a field, choose Sum.    When you choose Sum, Works prints the results 
using the label Total.

more...
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Creating a report, cont.
If you want, you can position the statistics under each column instead of together in rows.

more...
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Creating a report, cont.
You're done--Works creates a report definition based on the choices you made.    

more...
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Creating a report, cont.
In many cases the report definition is all you need, but you can also change the report's appearance and 
organization once it has been created.    For more information, see Changing a Report.
You can create up to eight reports for each database.    If you change the information upon which the report is 
based, Works automatically updates the report to match.

How to
            Create a report  

Related information
            Changing a report  
            Naming a report  
            Previewing  
            Printing  
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Overview
When you create the first report for a database, Works names the report "Report1".    If you create a second report 
for the same database Works names it "Report 2," and so on.    You may want to give the report a more descriptive 
name--particularly since you can create up to eight reports for each database.

How to
            Name a report  

Related information
            Deleting a report  
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Overview
When you change a report, you work in report definition view.    Skills that you use in list view--such as moving, 
highlighting, and changing the column width--are much the same in this view.    For a quick review of those skills, or 
a tour of report definition view, read this topic; otherwise, see Changing a Report.

Related information
            Changing a report  
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Understanding report definition view
There are many things about report definition view that are similar to form view and list view...

more...
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Understanding report definition view, cont.
The important thing to understand is how the labeled rows correspond to your printed report, for example: 
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Moving within a report definition
When changing or viewing your report, you can move from one part of the report definition to another using the 
scroll bars or keyboard--just like you do in list view.

How to
            Move in report definition view using the mouse  
            Move in report definition view using the keyboard  
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Changing column width
If you can't see complete entries in a column, you may want to change the column width.    For example, you may 
want to change the width of column E so you can see the entire entry =SUM(Value).

Changing the column width affects the amount of space between entries when you print your report.    If you have 
adjusted the column width while working on a report definition, you may want to readjust the width before you 
print. For more information, see Changing the Page Layout.
How to

            Change the column width  
Related information

            Changing the page layout  
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Highlighting in a report definition
Before you make changes, you need to highlight the information you want to work with.    Highlighting in report 
definition view is similar to highlighting in list view.

How to
            Highlight one entry  
            Highlight several entries  
            Highlight a column  
            Highlight a row  
            Highlight the entire report definition  

Related information
            Changing a report  
            Editing entries in report definition view  
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Overview
Editing entries in report definition view is very much like editing information in list view.    If you already know how 
to change, copy, move, delete, or add new entries, you can skip this topic.

Related information
            Changing a report  
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Editing an entry
If you want to change an entry, you can either edit part of the entry or replace the entire entry with new text.
     To revise an entry, highlight it and then edit it in the formula bar.
     To replace an entry, highlight it and then type new text.    As you type, the new text replaces the old entry.

How to
            Edit part of an entry  
            Replace the entire entry  

Related information
            Keys for editing in the formula bar  



Editing entries in report definition view
 3 of 6 

Adding an entry
If you want to add information to your report definition, move the highlight to the location you want the information 
to appear and then type the new text.    If you want to add the information between existing entries, insert a new 
row or column first.    For example:

How to
            Add an entry  
            Insert a column  
            Insert a row  

Related information
            Changing a report  
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Removing entries
There are two ways you can remove information from a report definition:    clearing and deleting. When you clear an 
entry, Works removes the information but retains the formatting  ,   so that new information you type has the same 
format as the old entry.    When you delete an entry, you remove both the entry and the formatting.

How to
            Clear an entry  
            Delete an entry  

Related information
            Keys for editing in the formula bar  
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Moving entries
If you want to move information, you can save time by cutting and pasting to the new location rather than deleting 
the information and typing it again.    In the example below, if you want the headings (Dept, Quantity, and Cost) to 
appear directly above the information in the report, you can move them down a row.
{ewc KSCOPE, WinDoc Bmp, 
rpmain3.22}

    Before
    After

If you want to place moved information between existing entries, insert a row or column first.

How to
            Move an entry  
            Insert a column  
            Insert a row  

Related information
            Changing a report  
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Copying entries
If you want to repeat text in your report, you can copy and paste to the new location rather than typing the text 
again.    If you want to place the information between existing entries, insert a new row or column first.

For information on copying a an entire report to another tool or application, see Copying a Report. 

How to
            Copy an entry  
            Insert a column  
            Insert a row  

Related information
            Changing a report  
            Copying a report  
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Overview
This topic shows you how to change the appearance and organization of a report you've created.

For information on changing the font, style, or alignment of text, see Changing Text Appearance.    For information 
on sorting records, see Sorting and Adding Subtotals.

Related information
            Changing text appearance  
            Sorting and adding subtotals  
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Opening an existing report
All the reports you have created for a database are listed on the View menu.

How to
            Open an existing report  

Related information
            Naming a report  
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Changing the title
The text you type in a title row of the report definition prints at the top of the first page of your report. 

Why are there two title rows?
The first title row contains the title of your report.
The second title row, which is empty, leaves a blank row between the title and headings when you print the 
report.    You can delete this row or insert as many title rows as you want for additional text or space.

more...
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Changing the title, cont.
If you don't know how to change the title (edit, replace, or move it), see Editing Entries in Report Definition View.

How to
            Insert a row  
            Delete a row  

Related information
            Editing entries in report definition view  
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Changing the headings
The text you type in a heading row of the report definition prints at the top of every page as field headings.

Why are there two heading rows?
The first heading row contains headings for the fields in your report.
The second heading row, which is empty, leaves a blank row between the headings and fields when you print 
the report.    You can delete this row or insert as many heading rows as you want for additional text or space.

more...
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Changing the headings, cont.
If you're using field names as headings, instead of typing them, you can have Works insert them for you.    This way 
you don't have to remember exactly how you spelled or abbreviated the field names.

more...
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Changing the headings, cont.
If you want to print a continuous line beneath the headings, you can enter it in a blank heading row.

You can also set off headings from other information in your report by making them bold, underline, or italic.    For 
more information, see Changing Text Appearance.
How to

            Delete a row  
            Insert a field name  
            Add a continuous line  
            Insert a row  

Related information
            Changing text appearance  
            Editing entries in report definition view  
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Changing the information
The record row contains the instructions that tell Works which fields to include in the report.

Why is there only one record row?
So that the records print one after the other without a blank row between records.
You can insert as many record rows as you want or even delete this row to print a report that includes only 
summary information.

more...
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Changing the information, cont.
If you add more than one record row, Works prints the same number of rows for each record in your report as the 
report definition contains.    For example:

more...
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Changing the information, cont.
As a fast and accurate alternative to typing instructions, you can have Works insert them for you.    If you want to 
position an instruction between existing entries, insert a blank column or row first.

When you print, the entries in that field will be included in your report.

more...
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Changing the information, cont.
You can change the records that are printed in your report in the following ways:

To Switch to
Hide individual records List view, then highlight the

records and choose the 
Hide Record command; see
Hiding Fields and Records

Find records that match
exactly one condition, 
such as a single date or
city

List view, then choose the 
Find command to locate 
them; see Finding Records

Find records that match
more than one 
condition or a range of 
conditions

Query view, then define a 
query; see Querying

How to
            Delete a row  
            Insert a column  
            Insert a field entry  
            Insert a row  

Related information
            Editing entries  
            Hiding fields or records  
            Finding records  
            Querying  
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Changing the summary information
Whatever you type in a Summary row is printed once at the end of the report.

Summary information can be anything from statistics, such as the total of values, number of items, or average of 
entries in a field, to explanatory text.    You can insert as many summary rows as you need for information you want 
printed at the end of your report.

more...
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Changing the summary information, cont.
As a fast and accurate alternative to typing summary instructions, you can have Works insert them for you.

How to
            Delete a row  
            Insert a field summary  
            Insert a row  

Related information
            Editing entries in report definition view  
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Overview
You can rearrange the records in your report so that they are organized alphabetically or numerically--just like you 
can in form view or list view.      However, in a report you can also add "breaks" between groups of records, where 
Works calculates subtotals for each group.

Related information
            Sorting records  
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Sorting and grouping records
You can organize records in your report in ascending or descending order.    For example, if you sort on the 
Department field in ascending order you get the following report:    

You can sort on up to three fields at the same time.    If entries in the first field are the same, Works sorts by entries
in the second field, and so on.

more...



Sorting and adding subtotals
 3 of 7 

Sorting and grouping records, cont.
Sorting may be all you want to do to your report .    However, you can add space or subtotals at the end of each 
group of related records by sorting and "breaking" on a field.

more...
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Sorting and grouping records, cont.
When you break on a field, Works adds a summary row, named after the field, to your report definition.    A summary
row prints after each group of related records.

more...
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Sorting and grouping records, cont.
You can edit, delete, or add to the entries in a summary field row.    For example, you may want to delete all of the 
subtotal entries but two and then type text to identify them.

more...
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Sorting and grouping records, cont.
If you want, you can also add headings that print at the beginning of each group, by inserting one or more 
Introductory rows for the field.

more...
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Sorting and grouping records, cont.
A quick review...

You can By
Organize records 
alphabetically or 
numerically

Sorting on fields

Organize and group records
(with subtotals)

Sorting and breaking on
fields 

Add headings to each 
group

Inserting an 
introductory row 

Note:    Works inserts a summary row for each field you break on.    

How to
            Sort records and add breaks  
            Insert an introductory row  

Related information
            Changing a report  
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Overview
If you want to create a report that is very similar to one you've already created, it may be faster to duplicate the 
existing report and change it as necessary rather than create another report from scratch.

How to
            Duplicate a report  



Deleting a report
 1 of 1 

Overview
When you no longer need a report, you can delete it.    Also, since each database can have no more than eight 
reports, you may have to delete an existing report before creating a new one.    When you delete a report, its name 
no longer appears on the View menu.    Works automatically renumbers the remaining reports.

How to
            Delete a report  
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Overview
Before you print, you may want to change the font, size, style, or alignment of text to make your report more 
attractive and easier to read or understand.

Note:    If you don't understand how the changes you make in report definition view affect your printed report, see 
Changing a Report.

Related information
            Changing a report  
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Changing the font and size
You can change the font or font size Works uses to print your report.    For example, you may want to switch to a 
smaller font size to print more information on a page. You can choose only one font for each report.    The fonts 
available to you are determined by the printer you are using.
{ewc KSCOPE, WinDoc Bmp, 
rpmain3.61}

    Helv 8pt
    Courier 9pt

If it is important to you that the width of characters is exactly the same for both text and numbers and that 
character line up precisely, then choose a non-proportional font (also called fixed-pitch).    However, 
proportional fonts are generally more pleasing to the eye.
How to

            Change the font and size  
Related information

            Background:    Fonts  
            Choosing a printer  
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Changing the style
You can vary the style of information in your report to emphasize specific text; for example, you may want to draw 
attention to titles or headings by making them bold, italic, or underline.

Note:    If you don't understand how the changes you make in report definition view affect your printed report, see 
Changing a Report.

How to
            Change the style  

Related information
            Changing a report  
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Changing the alignment
You can change the way entries are aligned within a column.    In some cases, this can make the information in your 
report easier to read. It can also give your report a more polished appearance.    Until you make a change, Works 
uses General alignment.

Note:    If you don't understand how the changes you make in report definition view affect your printed report, see 
Changing a Report.

How to
            Change the alignment  

Related information
            Changing a report  
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Overview
To add text that prints at the top or bottom of every page, such as titles, dates, times, or page numbers, you can 
create headers and footers.

Related information
             Changing the page layout  



Headers and footers
 2 of 7 

Creating a header or footer 
You can create a one-line header or footer that will print at the top or bottom of every page of your report.

When you create a header or footer, you can use codes to change the alignment of text or to have Works 
automatically insert the filename, page number, or current date or time.    Until you change the alignment, Works 
automatically centers headers and footers.

more...
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Creating a header or footer, cont.
To                                                                 Type this code  

more...
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Creating a header or footer, cont.
To                                                                 Type this code  

more...
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Creating a header or footer, cont.
To                                                                 Type  

Notes:
The text for a header or footer is not displayed in your document, but you can see it when you preview or print
your database.
If you number the pages, you can set the starting page number.    For example, if you want to combine several 
documents into one document, you can set the starting page number for each document so that the pages 
are numbered consecutively.

How to
            Create a header or footer  
            Delete a header or footer  
            Change the starting page number  
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Adjusting header and footer margins
After you have created a header or footer, you may want to adjust the header or footer margins so that you can 
change where the header or footer prints on the page. 

How to
            Adjust header or footer margins  
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Printing headers and footers
Unless you specify otherwise, Works prints a header or footer on every page of your document.    However, you can 
choose to print the first page of your document without a header or footer.

If you do not want a header or footer to print on any of the pages, you need to delete the header or footer.
How to

            Print without a header or footer on the first page  
            Delete a header or footer  
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Overview
You can change the layout and amount of information printed on each page of your report by changing the margins,
the space between columns, the page size or orientation, and by adding your own page breaks.

Related information
            Lesson:    Page layout and printing  
            Printing  
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Adjusting page margins
You can control the amount of space between the edge of the page and printed text by increasing or decreasing the
margins.    If you have created headers or footers, make sure that the header margin is smaller than the top 
margin and that the footer margin is smaller than the bottom margin.

How to
            Adjust margins  

Related information
            Headers and footers  
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Changing space between columns
If you want to change the amount of space between columns, you can either increase or decrease the column width
or insert blank columns between existing columns.    

For information on changing the alignment of information within a column, see Changing Text Appearance.
How to

            Change column width  
            Delete a column or row  
            Insert a column  

Related information
            Changing text appearance  
            Printing  
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Inserting and deleting page breaks
You can change the amount of information printed on a page by manually inserting page breaks. When you insert a 
page break, Works adjusts the other page breaks in the document.    When you print a large report, pages are 
divided and printed in the order shown below.

If the report is not arranged as you would like it, you can insert horizontal or vertical page breaks.

more...
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Inserting and deleting page breaks, cont.
For example, if you have added a break to the Dept field but want each group to print on a separate page, you can 
insert a page break after the summary row for the Dept field.

How to
            Insert a page break  
            Delete a page break  

Related information
            Printing  



Changing the page layout
 6 of 6 

Changing page size and orientation
You can print your database on paper of different sizes and in portrait (vertical) or landscape (horizontal) 
orientation. Until you change the setting, Works is set to print on letter-size (8.5-by-11-inch) paper in portrait 
orientation.

Not every printer can print text in landscape orientation. If you are not sure about your printer, check your printer 
manual. 
How to

            Change the page size  
            Change the page orientation  

Related information
            Printing  
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Overview
Before you print your report, it is a good idea to preview it to make sure that information is set up on the page 
exactly as you want.    In print preview, margins, page breaks, and headers and footers are shown as they will 
appear when you print your report.

How to
            Preview a document  

Related information
            Changing the page layout  



Printing
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Overview
When you print a report, you can either print the entire report or one that contains only the title, headings, and 
summary information.    Before you print, be sure to preview the report to verify that the report is laid out exactly as 
you want it.

If you want to change margins, page size or orientation, page breaks, or space between columns, see Changing the 
Page Layout.    If you want to add text that prints on every page, such as page numbers, dates, or titles, see 
Headers and Footers.
How to

            Print a report  
Related information

            Changing the page layout  
            Previewing  
            Headers and footers  
            Choosing a printer  



Copying a report
 1 of 1 

Overview
You can copy a report's results--the same information that you would get if you printed the report--to another Works
tool or Windows application.    For example, you may want to copy information from a report to a word processor 
document.

If you copy to the Word Processor, each entry is separated from the next by a tab mark () and each row ends with a 
paragraph mark (). If you copy to the Spreadsheet, each entry is copied into a separate cell.    Columns and rows are
preserved.

How to
            Copy a report  
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Overview
You can select the records that are included in a report by changing the records Works displays.    To display 
records that match more than one condition, you need to define a query.

To display records that match only one condition, such as a single date or last name, see Finding Records.

Related information
            Lesson:    Advanced searching  
            Finding records  
            Hiding fields or records  
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What is a query?
A query is a way for you to find records or ask questions about the information in your database.    A query can be 
very simple; for example, which customers have orders greater than $500.00?    

{ewc KSCOPE, WinDoc Bmp, 
dbmain2.28} Example

             Before  
             After  

Note:    Query view looks just like form view except that you type instructions rather than entries.
more...
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What is a query?, cont.
The real power of a query lies in the fact that you can find records that have more than one entry in common, 
entries in which part of the entry varies from record to record, or entries that fall within a specified range.    For 
example, which customers have the last name Smith, and orders greater than or equal to $500.00 but less than 
$600.00?

{ewc KSCOPE, WinDoc Bmp, 
dbmain2.30} Example

             Before  
             After  
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Defining a query
To define a query, you switch to query view, enter the instructions that tell Works which records to display, and 
then apply the query by switching to form, list, or report definition view.

more...
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Defining a query, cont.
You can then type the instructions in the fields to indicate which records you want to find.    For more information, 
read the "What do I type" section of this topic which begins on page 6.
When you apply the query by switching to form or list view,    Works searches all your records including the hidden 
ones, and then displays the matching records in the view you selected.    If you switch to a report definition, you will 
not see records, but only records matching the query will be printed.

How to
            Define a query  
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What do I type?
To find records containing entries that are an exact match or that fall within a specific range of values, you can use
the following comparison operators:

= equal to < less than <= less than or equal
to

<> not equal to > greater than >= greater than or 
equal to

{ewc KSCOPE, WinDoc Bmp, 
dbmain2.35}

Click to see an example

             Last name equal   
to Smith

             Last name is   
anything but Smith

             Balance less than  
$500

             Balance greater   
than $50

             Date is Oct 30,   
1991 or earlier

            Date is Oct 30,   
1991 or later

more...
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What do I type?, cont.
To find records in which part of a text entry varies from record to record, you can use the following "wildcard" 
symbols:      

? Use to represent one character appearing in the same position as the question mark.
* Use to represent any number of characters appearing in the same position as the asterisk.

{ewc KSCOPE, WinDoc Bmp, 
dbmain2.41} Click to see an example

            Last names   
spelled similarly

            Last names that  
begin with Peters

            Last names that  
begin with S

            All addresses   
on 24th St

            Phone numbers  
that start with the prefix 
555

more...
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What do I type?, cont.
To perform a mathematical operation using values from one or more numeric fields in your database, you can use 
any of the following mathematical operators:

- subtraction / division ^ exponentiatio
n

+ addition * multiplication
When you type a formula, you must start with an equal sign (=) unless the formula begins with <, <=, >, >=, or 
<>.
{ewc KSCOPE, WinDoc Bmp, 
dbmain2.46}

Click to see an example

            Stores whose   
profit is greater than 
$1000

            Stores whose   
cost is less than the 
investment plus $1000

            Stores whose   
growth has more than 
doubled

            Stores whose   
profit is greater than 1 1/2
times the investment

            Sales greater   
than $1,000,000

more...
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What do I type?, cont.
To specify more than one condition that applies to one or more fields, you can use the following logical operators:
& (AND) Use to combine two or more conditions.

(OR) Use to find records when either one or the other criteria is TRUE.
~ (NOT) Use to negate conditions.

When you specify more than one entry in a field, you must enclose each entry in quotation marks.    For example, if 
you want to find the records of only those customers living in Washington (WA) or New York (NY), you would type 
the following instruction in the query form...

Also, notice that in this example you cannot omit any of the equal signs (=).    The first equal sign indicates that the 
instruction is a formula.    The equal signs before WA and NY indicate that you want to find records containing 
entries equal to " WA"    OR equal to "NY".

more...
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What do I type?, cont.
Remember that when you type a formula, you must start with an equal sign (=) unless the formula begins with <, 
<=, >, >=, or <>.

{ewc KSCOPE, WinDoc Bmp, 
dbmain2.52}

Click to see more 
examples

            All clients who   
live in either Seattle or 
Tacoma

            All clients who   
do NOT live in Seattle or 
Tacoma

            All clients who   
earn at least $50,000 
AND less than $80,000

Related information
            Background:    How Works evaluates formulas  
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Looking at the results of a query
Once you have applied the query, you can further change the records that are displayed as a result of a query.    

To You can
Further refine the results 
of the query

Hide individual records

See all the records that 
do not match your query 

Switch hidden and displayed 
records

Display all the records in 
the database including 
previously hidden 
records 

Show all records

If you display all the records and then edit records or add new ones, you can reapply the query to see which records
now match the query instructions.

How to
            Hide a record in list view  
            Switch hidden and displayed records  
            Display all records  
            Reapply the last query  
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Changing or deleting a query
When you define a query, Works saves the instructions.    The next time you switch to query view, the previous 
instructions appear in the query form.    If you want to change the instructions, you can either edit them or delete 
the entire query and start over.

How to
            Edit an instruction  
            Replace an instruction  
            Clear an instruction  
            Delete the entire query  
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from the indented sections of the list below.
Getting started
               Report basics  
               Creating a report  
               Naming a report  

Making changes
               Introducing report definition view  
               Editing entries  
               Changing a report  
               Sorting and adding subtotals  

            Querying  
            Duplicating a report  
            Deleting a report  

Enhancing the appearance
            Changing text appearance  

Printing
            Headers and footers  
            Changing the page layout  
            Previewing  
            Printing  

Using with other tools or applications
            Copying a report  



           Active window, defined  
Addition

            queries  
            subtotals  
            totals  

Alignment
            changing, how to  
            described  

headers/footers
            described  
            how to  
           Alphabetizing records        (See Sorting)  
           AND as logical operator  

Appearance of text
            aligning      (See Alignment)  
            bold      (See Bold)  
            font      (See Font)  
            italic      (See Italic)  
            overview  
            underline      (See Underline)  

Arranging
            icons, how to  
records
            moving      (See Moving information)  
            sorting      (See Sorting)  
           Ascending order        (See Sorting)  

Asterisk (*) in queries
            multiplication operator  
            wildcard symbol in queries  
           Audio check  
           Automatic dialing        (See Dialing phone numbers)  

AVG function
            how to use  
            summary row, how to enter  



           Backup copy, how to create  
           Blank report definition, how to create  

Blank space
            adding after sort  

columns
            deleting blank column, how to  
            described  
            increasing/decreasing by adjusting column width, how to  
            inserting blank column, how to  
rows
            after headings  
            after titles  
            deleting blank row, how to  
            inserting blank row, how to  

Bold
            (See also Style)  
            applying style, how to  
            printing without, how to  
           Boolean searches  
           Breaking a report        (See Grouping records)  



Calculating report statistics
            applying to report, how to  
            positioning in report, how to  
            printing  
            specifying, how to  

Canceling
            automatic dialing, how to  

dialog box and command
            keyboard method, how to  
            mouse method, how to  
            preview, how to  

Cascading windows
            described  
            how to  

Centering information
            header/footer code, how to use  
            report definition view, how to change  

Centimeters, as unit of measure
            changing, how to  
            described  

Character formatting
            bold/italic/underline      (See Style)  
            font and point size      (See Font)  
           Charting tool, described  

Clearing
            deleting and clearing compared  
            entries, how to  
            query instructions, how to  

Closing documents
            described  
            how to  
            overview  
           Codes for header/footer, how to use  

Column
alignment in report
            changing, how to  
            described  
            deleting, how to  
            highlighting, how to  
            inserting, how to  
            space between columns  

width
            changing, described  
            changing, how to  

Commands
            choosing, how to  
            illustrated  



lessons
            Getting to work  
            Using the keyboard  
            Using the mouse  
            overview  
           Comparison operators  
           Control-menu box, illustrated  

Copying
            alignment, how to  

entries
            described  
            how to  
report results to another application
            how to  
            overview  
reports
            how to  
            overview  
            styles, how to  

COUNT function
            how to use  
            summary row, how to enter  

Country settings
            changing, how to  
            overview  

Creating
document in Works
            described  
            overview  
report
            defining report elements      (See Report definition)  
            described  
            how to  
            lesson:    Reporting  
            overview  



Database
            changing, effect on report  

deleting reports
            how to  
            overview  
            number reports allowed  
           Database tool, described  

Date
            background reading  

international settings
            changing, how to  
            overview  
            printing in header/footer, how to  

Defining a query
            comparison operators  
            described  
            how to  

Deleting
            clearing and deleting compared  
            column, how to  

entries
            described  
            how to  
            headers/footers, how to  
            page breaks, how to  

Deleting continued...
queries
            described  
            how to  
reports
            how to  
            overview  
            row, how to  
           Descending order        (See Sorting)  
           Designing a report        (See Page layout)  

Dialing phone numbers
            canceling, how to  
            changing settings, how to  
            described  
            how to use  
            overview  

Dialog box
            described  
            overview  

using
            keyboard, how to  
            mouse, how to  

Displaying



            status bar, how to  
            Toolbar, how to  
           Division (/) in queries  

Document
closing
            described  
            how to  
            overview  
creating
            described  
            overview  
lessons
            Getting to work  
            Working with files  

Document continued...
naming
            described  
            how to  
            number of characters allowed  
            overview  
opening
            described  
            how to  
            overview  
            preventing changes, how to  

saving
            described  
            how to  
            overview  

Document window
            described  
            status bar/Toolbar, how to show and hide  
           Draft quality printing, how to choose  
           Duplicating        (See Copying)  



Editing
            described  
            entire entry, how to  
            overview  
            partial entry, how to  

query instructions
            described  
            how to  
            report title  
            revising and replacing, compared  
           Emphasizing text        (See Style)  
           Ending preview, how to  
           Enlarging a window, how to  

Entry
adding
            described  
            how to  
clearing and deleting
            clearing, how to  
            deleting, how to  
            described  

Entry continued...
            copying      (See Copying)  
            editing      (See Editing)  
            highlighting      (See Highlighting)  

moving
            described  
            how to  
            text      (See Text)  
           Equal sign (=) in queries  

Erasing
            removing entry and formatting      (See Deleting)  
            removing entry while retaining formatting      (See Clearing)  
           Exchanging information between Works tools  

Exiting Microsoft Works for Windows
            described  
            how to  
           Exponentiation (^) in queries  
           Extending a selection, how to  



Field
adding to report
            described  
            how to  
specifying for report definition
            described  
            how to  
           Field heading        (See Heading in report)  

Field name as report heading
            described  
            inserting, how to  
           File       (See Document)  

Filename
            extension  
            printing in header/footer, how to  
           Finding (searching) records        (See Query)  

First page header/footer, preventing
            described  
            how to  

Font
            available fonts  
            background reading  
            changing, how to  
            printing limitations, how to correct  

Footer
            creating, how to  
            deleting, how to  
            described  
            displaying  

margins and placement in document
            adjusting, how to  
            bottom page margin, relationship  
            described  
            overview  

Footer continued...
preventing on first page
            described  
            how to  
previewing
            described  
            how to  
printing
            codes, how to use  
            described  
starting page
            changing, how to  
            setting  

Formatting
            alignment      (See Alignment)  



characters
            bold/italic/underline      (See Style)  
            font and point size      (See Font)  
            clearing/deleting entries, effect  
            date, how to  
            footers      (See Footer)  
            headers      (See Header)  
            margins      (See Margin)  
            printing without, how to  
            time, how to  
           Functions, how to enter in summary row  



General alignment
            changing, how to  
            described  
           Greater than or equal to symbol (>=) in queries  
           Greater than symbol (>) in queries  

Grouping records
            adding space  
            described  
            how to group (sort)  

summary row
            adding, how to  
            described  



           Hard page break        (See Page break)  
Header

            creating, how to  
            deleting, how to  
            described  
            displaying  

margins and placement in document
            adjusting, how to  
            bottom page margin, relationship  
            described  
            overview  

Header continued...
preventing on first page
            described  
            how to  
previewing
            described  
            how to  
printing
            codes, how to use  
            described  
starting page
            changing, how to  
            setting  

Heading in report
            (See also Introductory row)  

blank space after
            deleting blank row, how to  
            described  
            inserting blank row, how to  
            changing  

continuous underscore
            adding, how to  
            described  
field name
            described  
            inserting, how to  
           Heading row  

Help basics
movies
            Getting around Help  
            Welcome to Help  
            Working strategies  
            overview  
           Hidden record, effect on querying  

Hiding
            status bar, how to  
            Toolbar, how to  

Highlighting
            column, how to  



            described  
entries

            multiple, how to  
            single, how to  
            report definition, how to  
            row, how to  

Horizontal page break
            deleting, how to  
            inserting, how to  
           Horizontal page orientation        (See Landscape orientation)  



Icon
            arranging, how to  

minimizing/restoring document window
            described  
            how to  
           Ideas for creating Works documents  

Inches, as unit of measure
            changing, how to  
            described  

Inserting
            column, how to  
            date, how to  
            fields      (See Field)  
            introductory row, how to  

page breaks
            described  
            how to  
            row, how to  
            summary information, how to  
            time, how to  

International settings
            changing, how to  
            overview  

Introductory row
            described  
            inserting, how to  

Italic
            (See also Style)  
            applying style, how to  
            printing without, how to  





Keyboard
            dialog box, how to use  
            moving around in report, how to  
            shortcut for commands, illustrated  



Landscape orientation
            described  
            font limitations, how to correct  

Learning Microsoft Works for Windows
lessons
            How to learn Works  
            What you need to know about computers  
            overview  

Left alignment
            header/footer text, how to change  
            report definition view, how to change  
           Legal size page, how to select  
           Less than or equal to symbol (<=) in queries  
           Less than symbol (<) in queries  

Lessons
When you click on one of the lesson titles listed below, the lesson will begin playing immediately.    When it is 
finished, you can find more information and instructions on how to perform a task by clicking on the See also 
reference that follows the lesson title.

            described  
            Getting to work  
            (See also Commands)  
            (See also Document)  
            How to learn Works  
            (See also Learning Microsoft Works for Windows)  
            Introducing the tools together  
            (See also Tools)  
            overview  

Lessons continued...
            Page layout and printing  
            (See also Margin)  
            (See also Page break)  
            (See also Printing)  
            Reporting  
            (See also Creating)  
            starting, how to  
            What you need to know about computers  
            (See also Learning Microsoft Works for Windows)  

Lessons continued...
            Working with files  
            (See also Document)  
            Working with windows  
            (See also Window)  
            Using the keyboard  
            (See also Commands)  
            Using the mouse  
            (See also Commands)  

Lines in report headings
            adding, how to  
            described  



           Lining up text        (See Alignment)  
           List separator, international settings  
           Logical operators  



           Magnify page in preview, how to  
           Manual page break        (See Page break)  

Margin
adjusting
            described  
            how to  
            changing, how to  

header/footer
            adjusting, how to  
            described  
            lesson:    Page layout and printing  
            overview  

previewing
            how to  
            overview  
           Matching query results       (See Query)  
           Mathematical operators in queries  

MAX function
            how to use  
            summary row, how to enter  
           Maximize box, illustrated  
           Menu, illustrated  

Menu bar
            illustrated  
            Works window  

Microsoft Works for Windows
            charting tool  
            database tool  

help movies
            Getting around Help  
            Welcome to Help  
            Working strategies  
            overview of tools  

quitting
            described  
            how to  

Microsoft Works for Windows continued...
            reporting tool  
            sharing information between tools  
            spreadsheet tool  

starting
            described  
            from MS-DOS, how to  
            from Windows, how to  
            last workspace arrangement displayed, described  
            last workspace arrangement displayed, how to  
            overview  
            word processor tool  

MIN function
            how to use  



            summary row, how to enter  
           Minimize box, illustrated  

Minimizing a window to an icon
            described  
            how to  

Modem, dialing phone numbers
            changing settings, how to  
            described  
            how to  
           More than or equal to symbol (>=) in queries  
           More than symbol (>) in queries  

Mouse
            dialog box, how to use  
            moving around in report, how to  

Movies
When you click on one of the movie titles listed below, the movie will begin playing immediately.    When it is 
finished, you can find more information and instructions on how to perform a task by clicking on the See also 
reference that follows the movie title.

            Getting around Help  
            (See also Help basics)  
            (See also Microsoft Works for Windows)  
            Welcome to Help  
            (See also Help basics)  
            (See also Microsoft Works for Windows)  
            Working strategies  
            (See also Help basics)  
            (See also Microsoft Works for Windows)  

Moving
dialog boxes
            keyboard method, how to  
            mouse method, how to  
            windows, how to  

Moving around
            document, scroll bars  
            keyboard method, how to  
            mouse method, how to  
            preview document, how to  
            report, described  

Moving information
            described  
            how to  
           Multiplication (*) in queries  



Naming
document in Works
            described  
            how to  
            number of characters allowed  
            overview  
report
            how to  
            number of characters allowed  
            overview  

New report
            creating, how to  
            described  
            overview  
           Non-proportional fonts  
           NOT as logical operator  
           Not equal to symbol (<>) in queries  

Number, international settings
            changing, how to  
            overview  

Numbering pages
printing in header/footer
            codes, how to use  
            described  
starting page
            changing, how to  
            setting  



Opening
document in Works
            described  
            how to  
            overview  
report
            described  
            how to  
           OR as logical operator  

Organizing reports
            moving      (See Moving information)  
            overview  
            sorting      (See Sorting)  

Orientation
            changing, how to  
            overview  
            portrait versus landscape  



Page break
            deleting, how to  
            described  
            inserting, how to  
            lesson:    Page layout and printing  
previewing
            how to  
            overview  
           Page design        (See Page layout)  

Page layout
            columns      (See Column)  
            footer      (See Footer)  
            header      (See Header)  

margins, adjusting
            described  
            how to  

Page layout continued...
orientation
            changing, how to  
            portrait versus landscape  
            overview  
            page break      (See Page break)  
            page size, how to select  
           Page margins        (See Margin)  

Page number
printing in header/footer
            codes, how to use  
            described  
starting page
            changing, how to  
            setting  
           Page preview        (See Previewing)  

Page size
            described  
            selecting, how to  
           Paper size for printing, how to select  
           Parts of a document window  

Phone numbers, dialing
            canceling, how to  
            changing settings, how to  
            described  
            how to  
            overview  

Picas, as unit of measure
            changing, how to  
            described  

Points
            point size        (See Font)  
unit of measure
            changing, how to  



            described  
Portrait orientation

            described  
            printing, how to select  

Positioning information
            aligning      (See Alignment)  
            moving      (See Moving information)  
           Power loss, effect on unsaved work  
           Practicing with Microsoft Works for Windows        (See Lessons)  

Preventing header/footer on first page
            described  
            how to  

Previewing
            canceling, how to  

headers/footers
            described  
            how to  
            how to preview  
            overview  
           Print preview        (See Previewing)  

Printer
            choosing, how to  
            overview  

Printing
            draft quality, how to  
            font limitations, how to correct  

headers/footers
            described  
            how to  
            preventing on first page, how to  
            horizontally on the page (landscape), how to  

Printing continued...
            how to print  

landscape orientation
            described  
            printer limitations, how to correct  
            lesson:    Page layout and printing  
            overview  
            page size  
            paper size, how to select  
            portrait orientation, how to select  
            previewed document, how to print  

Printing continued...
            printer      (See Printer)  
            problems, background reading  
            statistics in report  
            summary information  

text
            bottom of page      (See Footer)  
            top of page      (See Header)  
            totals in report  
            vertically on the page (portrait), how to  



Query
            applying, how to  
            clearing query instructions, how to  
            comparison operators  

defining
            described  
            how to  
deleting
            described  
            how to  

Query continued...
            described  

editing query instructions
            described  
            how to  
            logical operators  
            mathematical operators  
            narrowing results  

Query continued...
            overview  
            range of values  
            reapplying, how to  
            replacing query instructions, how to  

viewing results
            described  
            how to  
            wildcard symbols  

Query operators
            comparison operators  
            logical operators  
            mathematical operators  
            wildcard symbols  
           Query view  
           Question mark (?) as wildcard symbol in queries  

Quitting Microsoft Works for Windows
            described  
            how to  



           Read only document, how to assign  
           Record row  

Records included in report
breaks between
            described  
            inserting, how to  
            overview  
sorting (grouping)
            described  
            how to  
            specifying for report  
            (See also Query)  
summary row
            adding, how to  
            described  

Reducing a window
            described  
            minimizing to an icon, how to  
            moving borders, how to  

Removing
            entry and formatting      (See Deleting)  
            entry while retaining formatting      (See Clearing)  
           Renaming a report, how to  

Reordering records
            moving      (See Moving information)  
            sorting      (See Sorting)  

Repeating
            alignment, how to  
            information      (See Copying)  
            styles, how to  

Replacing
entries
            described  
            how to  
            query instructions, how to  

Report
            creating      (See Creating)  
            database changes, effect  

deleting from database
            how to  
            overview  
fields
            adding, described  
            adding, how to  
            specifying, described  
            specifying, how to  

Report continued...
naming
            how to  
            overview  



            number allowed per database  
            records specified  
            (See also Query)  
            statistics      (See Statistics)  

Report continued...
subtotals
            calculating, how to  
            described  
            title  
            totals  
            updating  
           Report basics  

Report definition
            blank, how to create  
            highlighting in      (See Highlighting)  
            illustrated  

moving around within
            described  
            keyboard method, how to  
            mouse method, how to  

Report definition view
            (See also Report definition)  
            described  
            overview  
           Reporting tool, described  
           Repositioning information        (See Moving information)  
           Restoring a window from an icon, how to  
           Revising entries        (See Editing)  

Right alignment
            header/footer text, how to change  
            report definition view, how to change  

Row
            adding, how to  
            deleting, how to  
            heading row  
            highlighting, how to  

introductory row
            adding to report definition, how to  
            described  

Row continued...
            record row  

summary row
            adding to report definition, how to  
            described  
            title row  
           Running head       (See Header)  



Saving a document in Works
            described  
            how to  
            overview  
           Scroll bar, illustrated  
           Scrolling  
           Search operators  
           Searching records        (See Query)  

Selecting (highlighting)
            column, how to  
            described  

entries
            multiple, how to  
            single, how to  
            report definition, how to  
            row, how to  
           Sharing information between Works tools  

Showing
            status bar, how to  
            Toolbar, how to  
           Sizing a window by moving borders, how to  

Sorting
            described  

grouping records
            adding space  
            described  
            summary row, described  
            summary row, how to add to report definition  
            how to sort records  
           Sound check  

Space, blank
            adding after sort  

columns
            deleting blank column, how to  
            described  
            increasing/decreasing by adjusting column width, how to  
            inserting blank column, how to  
rows
            after headings  
            after titles  
            deleting blank row, how to  
            inserting blank row, how to  

Spreadsheet tool
            copying report results to, effect  
            described  

Starting
Microsoft Works for Windows
            described  
            from MS-DOS, how to  
            from Windows, how to  



            last workspace arrangement displayed, described  
            last workspace arrangement displayed, how to  
            overview  
            tutorial, how to  

Starting page
            changing, how to  
            setting  
           Startup dialog box, how to use  

Statistics
            applying to report, how to  
            calculating, how to  
            positioning in report, how to  
            printing  

Status bar
            background reading  
            showing/hiding, how to  
            Works window  

STD function
            how to use  
            summary row, how to enter  

Style
changing
            described  
            how to  
            copying, how to  
            printing without, how to  
            removing, how to  

Subtotal in reports
            creating, how to  
            described  
            sorting (grouping) records  
           Subtraction (-) in queries  

SUM function
            how to use  
            summary row, how to enter  

Summary information printed in report
            described  
            printing in report  
            statistics for calculating, how to use  

Summary row in report definition
            adding, how to  
            described  

Suppressing header/footer on first page
            described  
            how to  



Telephone numbers, dialing
            canceling, how to  
            changing settings, how to  
            described  
            how to use  
            overview  

Text
            alignment      (See Alignment)  
            appearance, overview  
            emphasizing      (See Style)  
            font      (See Font)  
            printed at bottom of page      (See Footer)  
            printed at top of page      (See Header)  
            style      (See Style)  

Tiling windows
            described  
            how to  

Time
            background reading  

international settings
            changing, how to  
            overview  
            printing in header/footers, how to  

Title
blank space after
            deleting blank rows, how to  
            inserting blank rows, how to  
            described  
           Title bar, illustrated  
           Title row  

Toolbar
            background reading  
            showing/hiding, how to  
            Works window  

Tools
            charting tool  
            database tool  
            lesson: Introducing the tools together  
            overview  
            reporting tool  
            sharing information between Works tools  
            spreadsheet tool  
            word processor tool  
           Totals in report  

Tutorial
            described  
            lessons    (See Lessons)  
            overview  
            starting, how to  



           Typeface        (See Font)  



Underline
            (See also Style)  
            applying style, how to  

continuous under heading
            adding, how to  
            described  
            printing without, how to  
           Updating a report  



VAR function
            how to use  
            summary row, how to enter  

Vertical page break
            deleting, how to  
            inserting, how to  
           Vertical page orientation        (See Portrait orientation)  
           Volume check  



Width of column
changing
            described  
            how to  
           Wildcard symbols in queries  

Window
arranging multiple
            described  
            saving arrangement, described  
            saving arrangement, how to  
cascading
            described  
            how to  
icon
            arranging, how to  
            described  
            minimizing/restoring document window, how to  

Window continued...
            illustrated  
            lesson:    Working with windows  

moving
            described  
            how to  
            moving around within  
            number of documents open at once  
            parts  
            sizing by moving borders, how to  
tiling
            described  
            how to  
            Works window  

Word processor tool
            copying report results to, effect  
            described  
           Works window  

Workspace
            described  
            saving window arrangement, how to  







           Zooming page in preview, how to  



File Print Preview
Displays your report as it will appear when printed.    You can check the margins, page breaks, headers, and 
footers and so on.    To:

See the next page, click Next. 
See the previous page, click Previous.
Magnify the page half way, click Zoom In.
Move from one part of the magnified page to another, use the scroll bars

--or--
Press PAGE UP or PAGE DOWN.

Magnify the page all the way, click Zoom In twice.
Return to the full page, click Zoom Out once or twice depending on how many times you magnified the 

page.
Print the document, click Print.
Leave print preview, click Cancel.

Shortcut...
To choose Print Preview, click the Preview button on the Toolbar.

More information
            Previewing  



Edit Cut
Cuts highlighed entries and places them on the Clipboard.

You can then paste the entries in another location in the same report, another Works tool, or another Windows 
application.    To paste the entries, press CTRL+V.
You can paste the entries as many times as you like until you cut or copy other information to the Clipboard.

Shortcut...
To choose Edit Cut, press CTRL+X.
More information

            Moving entries  



Edit Copy
Copies highlighed entries and places them on the Clipboard.

You can then paste the entries in another location in the same report, another Works tool, or another Windows 
application.    To paste the entries, press CTRL+V.
You can paste the entries as many times as you like until you cut or copy other information to the Clipboard.

Shortcut...
To choose Edit Copy, press CTRL+C.
More information

            Copying entries  



Edit Copy Report Output
Copies the results of your report and places them on the Clipboard.

You can then paste the information in any open Works document, or another Windows application.    To paste the 
information, press CTRL+V.
You can paste the information as many times as you like until you cut or copy other information to the Clipboard.

More information
            Copying a report  



Edit Paste

Pastes entries you have cut or copied to the Clipboard at the position of the highlight ( ).
You can paste the entries as many times as you like until you cut or copy other information to the Clipboard.

Shortcut...
To choose Edit Paste, press CTRL+V.
More information

            Copying entries  



Edit Clear
Clears highlighed entries.    You cannot recover cleared information.

When you clear an entry, Works removes the entry but retains the formatting, so that the next entry you type 
in the same location has the same format as the cleared entry.

Shortcut...
To clear a highlighted entry, press DEL.    To clear more than one entry at a time, you must use the Clear command.
More information

            Removing entries  



Edit Delete Page Break
Choose to delete vertical or horizontal page breaks.

Works deletes a horizontal page break above a highlighted row or a vertical page break to the left of a 
highlighted column.
If you do not highlight an entire row or column, Works displays the Delete Page Break box asking which type of 
page break you want to delete.
Page breaks in report definition view do not affect those in form or list view.

More information
            Inserting and deleting page breaks  



Edit Insert Page Break
Choose to insert vertical or horizontal page breaks.

Works inserts a horizontal page break above a highlighted row or a vertical page break to the left of a 
highlighted column.
If you do not highlight an entire row or column, Works displays the Insert Page Break box asking which type of 
page break you want to insert.
Page breaks in report definition view do not affect those in form or list view.

More information
            Inserting and deleting page breaks  



Select Cells
Use when you want to highlight entries using the keyboard instead of the mouse.

When you choose Select Cells, you can extend the highlight from the position of the highlight () to the place you 
want by pressing the arrow keys ( ).    When Extend Highlight is on, EXT is displayed in the status bar.
To stop extending the highlight, choose this command again or press ESC.
If you want to cancel your selection, press an arrow key.

Shortcut...
To choose Select Cells, press F8.
More information

            Highlighting in a report definition  



Select Row
Choose to highlight one or more rows in report definition view.

When you choose Select Row, Works highlights the entire row in which the highlight () is located.
If you highlight more than one entry in a column and then choose this command, Works highlights the rows in 
which the entries are located.

More information
            Highlighting in a report definition  



Select Column
Choose to highlight one or more columns in report definition view.

When you choose Select Column, Works highlights the entire column in which the highlight () is located.
If you highlight more than one entry in a row and then choose this command, Works highlights the columns in 
which the entries are located.

More information
            Highlighting in a report definition  



Select All
Choose to highlight the entire report definition.    This is useful if you want to apply a change to the entire report, for
example, to change the style of all the text in the report.
More information

            Highlighting in a report definition  



Format General
Formats a highlighted entry to display numbers using General format.    In this format, numbers are displayed as 
precisely as possible given the width of the column containing the entry.

More information
            Changing the number format  



Format True/False
Formats a highlighted entry to display numbers using logical values.

If a number is anything but 0, its value is TRUE.
If a number is 0, its value is FALSE.

More information
            Changing the number format  



Options Show Toolbar
Choose to hide or show the Toolbar.

When the Toolbar is hidden, the check mark is no longer displayed beside Show Toolbar on the Options menu.
When the Toolbar is displayed, the check mark is displayed beside Show Toolbar on the Options menu.

More information
            Hiding the Toolbar or status bar  



View Form
Switches you to form view, where information is displayed one record at a time.    In form view, you can create a 
customized form, such as an invoice or statement.

When you create a new database, Works displays a blank form in form view.    The form can contain fields and 
descriptive text for the form called labels.

Shortcut...
To choose View Form, click the Form View button on the Toolbar.

More information
            Creating a database in form view  



View List
Switches you to list view, where records are displayed in a list.

Work in list view when you want to see and work with a group of records, such as when you are copying, sorting,
searching, applying a query, and so on.

Shortcut...
To choose View List, click the List View button on the Toolbar.

More information
            Creating a database in list view  



View Query
Switches you to query view.

In query view, Works displays a blank form.    You can enter instructions into the fields on the form to tell Works 
which records you want to include in your report.
If you have defined a query, your most recent query instructions, if any, are displayed on the form.

Shortcut...
To choose View Query, click the Query View button on the Toolbar.

More information
            Querying  



View (report name)
Opens the report in a database window.

More information
            Opening an existing report  



File Save As
Use to:

Name a database.
Save an exisiting database under a new name.
Save a database so you can use it with another application.
Create a template.

To rename a report, choose Name Report from the View menu.    For more information, see Naming a Report.
Shortcut...
More information

            Naming and saving a document  
            Naming a report  
            Sharing with other applications  



Format Time/Date
Use to change the format of dates or times in a report.    Highlight the entries whose date or time format you want 
to change, then choose the options you want.

More information
            Dates and times  



View Create New Report
Creates a new report based on information from your database.    You can add a report title and choose the 
database fields you want to include in the report.

Shortcut...
What if I want to create a report from scratch?
More information

            Creating a report  



What if I want to create a report from scratch?
Click OK without typing a title or adding fields.    Works will display a blank report definition you can customize.



View Report Statistics
Use to add summary statistics at the end of your report.    If you do not want to add statistics, click OK.

More information
            Creating a report  



View Name Report
As you create reports, Works names them Report1, Report2, and so on.    You can use this command to rename 
reports so that they have unique and descriptive names.

What if I get an "already exists" message?
More information

            Naming a report  



What if I get an "already exists" message?
You are trying to use a name another report already has.    Each database report must have a unique name. 



View Delete Report
Use to delete one or more reports from your database.    You can have up to eight reports per database.

More information
            Deleting a report  



View Duplicate Report
Use to quickly duplicate an existing report.    For example, you can create a series of reports summarizing different 
aspects of your database by duplicating the original and making minor changes.

More information
            Duplicating a report  



Edit Delete Row/Column

Deletes the row or column in which the highlight ( ) is located.    Works will delete a row or column without 
displaying the dialog box if you highlight an entire row or column before choosing Edit Delete Row/Column.

More information
            Removing entries  
            Changing a report  



Edit Insert Row/Column

Inserts a row above the location of the highlight ( ) or a column to the left of the highlight.    Works will insert a
row or column without displaying the dialog box if you highlight an entire row or column before choosing Edit Insert 
Row/Column.

More information
            Adding an entry  
            Changing a report  



Edit Insert Row
Use to insert a row in your report definition.

More information
            Changing a report  



Edit Insert Field Name
As an alternative to typing headings for the fields in your report, you can have Works insert the field names for 
you.

More information
            Changing the headings  



Edit Insert Field Entry
Instead of typing instructions in the Record row that tell Works which fields you want to include in your report, you 
can have Works insert them for you.

More information
            Changing the information  



Edit Insert Field Summary
Instead of typing a formula in the Summary row that tells Works to calculate summary information for a field in your
report, you can have Works insert the formula for you.

What if I put a summary statistic in a Record or Heading row?

More information
            Changing the summary information  



What if I put a summary statistic in a Record or Headings row?
Works will insert the statistic in the highlighted row, but the calculation will not necessarily reflect the information in
the specified field.    It's best to put summary statistics in Summary rows.



Edit Headers & Footers
Use to create a one line header or footer that prints at the top or bottom of every page.    You can insert and 
position page numbers, the date, or the time by typing codes with text.

To display more information in a header or footer, you can try using a different font, changing to a smaller font size, 
or setting smaller margins.

More information
            Headers and footers  
            Changing the font and size  
            Changing the page layout  



Select Sort Records
Use to organize your records alphabetically or numerically, in ascending or descending order, based on the 
contents of the fields you specify.    You can also add breaks and subtotals between groups of related records.

More information
            Sorting and adding subtotals  



Format Fixed
Formats highlighted entries to display numbers with the number of decimal places you specify.    Negative numbers 
are indicated by a minus sign.

Before I print, how can I tell if the columns are wide enough to display the numbers in my report?

More information
            Changing the number format  
            Changing column width  



Before I print, how can I tell if the columns are wide enough to display the numbers in my report?
Click the Preview button on the Toolbar.

If a column is too narrow, #### will be displayed.    Return to report definition view to change the column width.



Format Currency
Formats highlighted entries to display numbers with a currency sign, commas every three places, and the number 
of decimal places you specify.    For example, if you choose 2 decimal places, 1000 becomes $1,000.00.    Negative 
numbers are enclosed in parentheses.

Before I print, how can I tell if the columns are wide enough to display the numbers in my report?

More information
            Changing the number format  
            Changing column width  



Format Comma
Formats highlighted entries to display numbers with a comma every three places and the number of decimal places
you specify.    For example, if you choose 2 decimal places, 1234567.8 becomes 1,234,567.80.    Negative numbers 
are enclosed in parentheses. 

Before I print, how can I tell if the columns are wide enough to display the numbers in my report?

More information
            Changing the number format  
            Changing column width  



Format Percent
Formats highlighted entries to display numbers as percentages, with the number of decimal places you specify.    For
example, if you choose 2 decimal places, .50 becomes 50.00%.    Negative percentages are indicated by a minus 
sign.

Before I print, how can I tell if the columns are wide enough to display the numbers in my report?

More information
            Changing the number format  
            Changing column width  



Format Exponential
Formats highlighted entries to display numbers in exponential (scientific) notation, with the number of decimal 
places you specify.    For example, if you choose 2 decimal places, 1234567 becomes 1.23E+06.    Negative numbers
are indicated by a minus sign.

Before I print, how can I tell if the columns are wide enough to display the numbers in my report?

More information
            Changing the number format  
            Changing column width  



Format Leading Zeros
Formats highlighted entries to display numbers with the number of leading zeros you specify.    This command is 
useful for entering Zip Codes, invoices, and other numbers that begin with zero.    If you do not format an entry to 
display leading zeros, Works deletes them.

Before I print, how can I tell if the columns are wide enough to display the numbers in my report?

More information
            Changing the number format  
            Changing column width  



Format Font
Use to select a font and font size for your report.    You can select one font per report.

Shortcuts...

What if I don't see the font I want?

More information
            Changing the font and size  
            Choosing a printer  



What if I don't see the font I want?
The fonts and sizes you see listed are determined by the printer you are using.

If your printer doesn't support the font or size you want to use, you may be able to add additional fonts.    
For information on adding fonts, see your printer's documentation.

If you have access to more than one printer, you can choose another printer to see different fonts and 
sizes.    For more information, see Choosing a Printer.



Format Style
Use to apply alignment and styles to highlighted entries in your report.

Shortcuts...

More information
            Changing the style  



Format Column Width
Use to change a column's width.    You specify the width in number of characters.

Before I print, how can I tell if the columns are wide enough to display the numbers in my report?

More information
            Changing a report  



File Print
Use to:

Print the current document.
Specify how many copies you want to print.
Choose Draft Quality printing.

Shortcuts...
What if the printer won't print my document?

More information
            Printing  



What if the printer won't print my document?
Make sure you have chosen the correct printer, and that the printer is plugged in, connected to your computer, and 
loaded with paper.    If you have not selected a printer, choose the Printer Setup command from the File menu and 
choose the printer you want.



File Page Setup & Margins
Use to define the margins and page size when printing your report.

More information
            Changing the page layout  
            Headers and footers  
            Printing  



Help
When you click this button or press F1, Works displays this topic.



OK

To carry out the choices you've made, click OK or press ENTER.



Cancel

To close the dialog box without accepting changes, click Cancel or press ESC.



Control-menu box    

To close the dialog box without saving changes, double-click the Control-menu box or press ESC.



Title bar
Displays the name of the command.

To move the dialog box to a new location, move the mouse pointer over the title bar, hold down the mouse 
button, and drag until you move the dialog box where you want it.



File name
Lists all files in the current directory.

To name a file, type a name no more than eight characters long.    You can use any characters except for 
spaces and those shown below, which have a special meaning for MS-DOS.



Directories
Displays the current drive and directory (c:\msworks), followed by a list of subdirectories in the current directory.    If 
you want to name a file and save it in another directory, change to that directory.

To change to another directory, double-click the drive to see the other directories, then click the directory 
you want.

If you can't see all of the directory names, click the up or down arrow.



Drives
Displays the current drive.

To save the file on another drive, click the down arrow to see the list of drives, and then click the one you 
want.    For example, if you want to save the file on a floppy disk, click drive a:

Note:    When you choose another drive, the directories on that drive will be listed under Directories.    To change 
to another directory, click the one you want from the Directories list.



Make Backup Copy

Click to create a backup copy of the database.    An "X" appears in the box when the option is chosen.
To differentiate the copy from the original, Works adds the extension .BDB to the database copy.    The copy is 
updated each time you choose File Save or File Save As.



OK

To carry out the choices you have made, click OK or press ENTER.



Save File as Type
Saves the file as a Works database (Works DB), unless you choose another file type.    For example, you may want to
save the file in another format so you can open it in another application or use it as a template.
To save the file in another format, click the down arrow to see the list of choices, and then click the one you want.    
If you choose:

Text & Commas, entries are separated by commas, and text, dates, times, and numbers in currency or 
percent format are enclosed in quotation marks.

Text & Tabs (DOS), entries are separated by tabs, and number formats are saved.    Try this before choosing
Text & Tabs.

Text & Tabs, the text file is saved in ANSI format.    Entries are separated by tabs, and number formats are 
saved.    Only some Windows applications recognize this format.

dBaseIII or dBaseIV, the file is saved so you can open it in dBase.
DB template, the file is saved as a template, which you can use as a starting point to create other 

databases.    Once you save a file as a template, Works uses the template every time you create a new database.    If
you do not want to use the template, choose Works Settings from the Options menu and clear the Use Templates 
For Database box.



Shortcut...

To save a document, press CTRL+S.



Top Margin

To change the amount of white space between the top of a page and the top of the first line of text, type a 
new measurement.

The top margin is preset at 1".



Bottom Margin

To change the amount of white space between the bottom of a page and the top of the last line of text, 
type a new measurement.

The bottom margin is preset at 1".



Left Margin

To change the amount of white space between the left edge of a page and the left edge of text, type a new
measurement.

The left margin is preset at 1.25".



Right Margin

To change the amount of white space between the right edge of a page and the right edge of text, type a 
new measurement.

The right margin is preset at 1.25".



Header Margin

To change the amount of white space between the top of a page and a header, type a new measurement.
Note:    The header margin must always be smaller than the top margin.    The header margin is preset at 0.5".



Footer Margin

To change the amount of white space between the bottom of a page and the footer, type a new 
measurement.

Note:    The footer margin must always be smaller than the bottom margin.    The footer margin is preset at 0.75".



1st Page Number
When you create a header or footer to number the pages, Works assumes you want to begin with the number one.   
However, if you want to combine several documents into one document, you can set the starting page number for 
each document so that when you combine documents the pages are numbered consecutively.

To change the starting page number, type the number you want.
Note:    Works will only number the pages if you have created a header or footer.    For more information, see 
Headers and Footers.



Page Length and Page Width
Works is preset to print on 8.5" by 11" paper in Portrait (vertical) orientation.

To change the paper size, type a new page length or width.
To change the page orientation, switch the length and width measurements.    For example if you want to 

print horizontally on 8.5" by 11" paper, change the page length to 8.5" and the page width to 11".
Note:    When you change the paper size or orientation, you must also choose Printer Setup from the File menu and 
change the Paper Size and Orientation settings.    To print horizontally, choose Landscape orientation.



Page Length and Page Width
Works is preset to print on 8.5" by 11" paper in Portrait (vertical) orientation.

To change the paper size, type a new page length or width.
To change the page orientation, switch the length and width measurements.    For example if you want to 

print horizontally on 8.5" by 11" paper, change the page length to 8.5" and the page width to 11".
Note:    When you change the paper size or orientation, you must also choose Printer Setup from the File menu and 
change the Paper Size and Orientation settings.    To print horizontally, choose Landscape orientation.



Page Breaks Between Records
Works is preset to print only one record per page.

To print more than one record on a page, clear the checkbox.    The box appears empty when it is cleared.
Works prints as many complete records as it can fit on a page.



Space Between Records

To add space between records when printing more than one record per page, type a number.
For example, to leave an inch of space between records, type 1.



Print Which Records

To print all the records in your database except hidden ones, click All Records.
--Or--

To print only the currently displayed record, click Current Record Only.



Print Which Items

To print labels, field names, and entries, click All Items.
--Or--

To print only the entries, click Field Entries Only.



Print Field Lines

Click to print field lines--the dotted lines that are displayed next to each field name.    An "X" appears in the
box when the option is chosen.



Header

To create a header that prints at the top of every page, type any text and or codes you want.
For information on codes, click the colored text "codes" on this page.



Footer

To create a footer that prints at the bottom of every page, type any text and or codes you want.
For information on codes, click the colored text "codes" on this page.



No Header on 1st Page

Click to eliminate the header from the first printed page of a document.    An "X" appears in the box when 
the option is chosen.



No Footer on 1st Page

Click to eliminate the footer from the first page of a document.    An "X" appears in the box when the option
is chosen.



Use Header and Footer Paragraphs
This option is only available in the Word Processor.



Go To

To jump to a specific field or record number, type the field name or record number.
When you choose OK, Works moves to the field or record number you specified.

If you want to move to a field, you can also double-click its name in the Names list below.



Names
Lists existing field names.

To jump to a specific field, double-click the field name you want.    If you can't see all of the available field 
names, click the up or down arrow.



Shortcut...

To choose Select Go To, press F5.



Find What

Type the specific text or number you want to find.

If you are searching for text entries (not numbers), you can use a "wildcard" symbol to represent one or more 
characters.

The question mark (?) wildcard represents any single character in the same position.
For example, if you want to search for a name, but are unsure whether it is spelled Anderson or Andersen, type 
anders?n and Works will find either name.

The asterisk (*) wildcard represents any number of characters in the same position.
For example, if you type s*s, Works finds all text that begins with an "s" and ends with an "s", such as sales and 
salaries.



Match

To find the next record that contains a match, click Next Record.
To display only those records that contain a match, click All Records.

If you choose Next Record, Works moves to the next record containing a match.    To move to the following 
matching record, press F7.

If you choose All Records, Works displays the records that contain a match and hides the rest.    To show all 
the records again, choose the Show All Records command from the Select menu.



1st Field
1 Type the name of the most significant field you want Works to sort by.

Works sorts by the 1st Field first, and by a second and third field only if two or more records share the same 
information in the first sort field.

2 Choose Ascending or Descending.

To organize the record in ascending order (0-9 and from A-Z ), click Ascend.
To organize the record in descending order (Z-A and from 9-0), click Descend.



2nd Field
1 Type the field you want Works to sort by if entries in the first sort field are the same.
2 Choose Ascending or Descending.

To organize the record in ascending order (0-9 and from A-Z ), click Ascend.
To organize the record in descending order (Z-A and from 9-0), click Descend.



3rd Field
1 Type the name of the field you want Works to sort by if entries in the first and second sort fields are the same.
2 Choose Ascending or Descending.

To organize the record in ascending order (0-9 and from A-Z ), click Ascend.
To organize the record in descending order (Z-A and from 9-0), click Descend.



Number of decimals

To specify the number of decimal places, type a number between 0 and 7.
For example, if you type 3, Works rounds off 123.4568 to 123.457.



Number of decimals

To specify the number of decimal places, type a number between 0 and 7.
For example, if you type 2, Works displays 1255.5 as $1,255.50.



Number of decimals

To specify the number of decimal places, type a number between 0 and 7.
For example, if you type 1, Works rounds off 23456.78 to 23,456.8.



Number of decimals

To specify the number of decimal places, type a number between 0 and 7.
For example, if you type 1, Works displays .4568 as 45.7%.



Number of decimals

To specify the number of decimal places, type a number between 0 and 7.
For example, if you type 3, Works displays 72000000 as 7.200E+07.



Number of digits

To specify the number of digits you want displayed in the field, type a number between 0 and 7.
For example, if you specify 5 number places, 999 becomes 00999.    No decimals will be displayed.



Show

Click the date or time option you want.
For example, if you choose Month, Day, Works displays 10/03/91 as 10/91.



Time

Click the option you want.
If you choose 24 hour, Works displays Hour, Minute as 14:10.
If you choose 12 hour, Works displays Hour, Minute as 2:10 PM.



Date

Click the option you want.
If you choose Short, Works displays Month, Day, Year as 6/10/92.    Note:    Month Only has no short form.
If you choose Long, Works displays Month, Day, Year as June 10, 1992.



Font
Lists the fonts your printer supports.

Click the font you want.    If you can't see all of the available fonts, click the up or down arrow.



Size
Lists the font sizes your printer supports.

Click the font size you want.    If you can't see all of the available font sizes, click the up or down arrow.
Examples: 8pt 10pt 12pt



Shortcuts...
To change font or font size
1 On the Toolbar, click an arrow to see the list of choices.

2 Click the font or font size you want.
--or--
Type the font or size in the appropriate box.



Alignment
Until you change the alignment, Works uses General alignment (text left-aligned, numbers right-aligned).

To change the alignment of information in a field, click the option you want.



Styles

To apply one or more styles, click the ones you want.    An "X" appears in a box when the style is chosen.
Examples:    Bold and underlineBold and italic



Locked
Works initially locks all fields, although the lock has no effect until you choose Protect Data from the Options menu.  
When Protect Data is turned on, locked entries cannot be changed, formatted, or unlocked.    When a field is locked, 
an "X" appears in the Locked box.

If you want to protect some fields but not others, clear the Locked box for each field you do not want to 
protect before you choose Protect Data.    A box appears empty when it is cleared.



Slide to left
Choose to remove blank spaces between fields when you print your form.

Click to slide a highlighted field to the left when you print.    An "X" appears in the box when the option is 
chosen.

You will not see the change until you preview or print the document.    To see how the form will look when printed, 
click the Preview button on the Toolbar.

For more information on sliding fields to the left, see Printing a Form.



Shortcuts...
To apply styles

On the Toolbar, 
click

--or--
To apply Press
Bold CTRL+B
Italic CTRL+I
Underline CTRL+U

To align information

On the Toolbar, click

--or--
To align Press
Left CTRL+L
Center CTRL+E
Right CTRL+R

Width

To specify field width in number of characters, type a number between 0 and 79.
Note:    The maximum width may vary depending upon the font and font size you are using.



Height

To specify field height in number of lines, type a number between 0 and 325.
Note:    The maximum height may vary depending upon the font and font size you are using.



Report Title

Type a title for your report up to 256 characters long.



Select fields to include in Report and choose Add
Lists all fields in the database.

To add a field to your report, click the field name and then click Add.
Important:    Add the fields in the order you want them displayed in your report.    Repeat until you've added all the
fields you want.



Fields in Report
Lists fields added to the report.

To remove a field from the report, click the field name you want to remove and then click Remove.



Add

To add a field to your report, click a name in the Select Fields box and then click Add.



Remove

To remove a field from your report, click a name in the Fields In Report box and then click Remove.



OK

To accept the choices you have made, click OK.
If you did not add any fields to the report, Works displays a blank report definition which you can customize 
yourself.
If you did add fields to the report, Works displays the Report Statistics box where you can specify whether or not 
you want Works to calculate any information for the fields in your report.



Shortcut...

To choose View Create New Report, click...

...on the Toolbar.



Fields in Report
Lists the fields you've chosen to include in your report.

To calculate a summary statistic for a field, click the field name, then choose the function you want to 
apply to the field under Statistics.



Position Statistics

To position the statistics under the appropriate fields in the report, click Under Each Column.
--Or--

To list the statistics one after the other at the bottom-left of the report, click Together in Rows.



Statistics
Lists the seven functions you can use in a report to create summary statistics.

To add statistics to the end of your report, choose a field from the Fields In Report box, then choose the 
functions you want to apply to the field.    Repeat until you have added all the statistics you want for the fields in 
your report.

To                                                             Click  
Total entries in a numeric field Sum
Average entries in a numeric field Average
Count the number of entries in a field Count
Find the smallest value in a numeric field Minimum
Find the largest value in a numeric field Maximum
Calculate the standard deviation Standard
in a numeric field     Deviation
Calculate the variance in a numeric field Variance



Reports
Lists the reports you've created for the current database. 

Click the name of the report you want to rename.    If you can't see all of the available names, click the up 
or down arrow.



Name

Type a new name for the report up to 15 characters long.



Rename

To accept the new report name, click Rename.
You can rename as many reports as you want before choosing OK.



OK

To accept new report names you've added using the Rename button, click OK.
You can rename as many reports as you want before choosing OK.



Cancel

To cancel the dialog box and any changes you made using the Rename button, click Cancel. 



Reports
Lists the reports you've created for the current database.

Click the name of the report you want to delete.



Delete

To delete the report you've chosen in the Reports box, click Delete.
You can delete as many reports as you want before choosing OK.



OK

To accept changes you've made using the Delete button, click OK or press ENTER.
You can delete as many reports as you want before choosing OK.



Cancel

To cancel the dialog box and any changes you made using the Delete button, click Cancel or press ESC.



Reports
Lists the reports you've created for the current database.

Click the name of the report you want to duplicate.



Name

To name the duplicate report, type a name up to 15 characters long.
If you do not name the duplicate report, Works assigns it a name:    Report1, Report2, and so on.



Duplicate

To duplicate the report you chose in the Reports box, click Duplicate.



OK

To carry out the choices you have made, click OK or press ENTER.
You can duplicate as many reports as you want before choosing OK.



Cancel

To cancel the dialog box and any changes you made using the Duplicate button, click Cancel or press ESC.



Record or Field

To delete the record in which the highlight is located, click Record
--Or--

To delete the field in which the highlight is located, click Field.



Record or Field

To insert a record above the position of the highlight, click Record.
--Or--

To insert a field to the left of the highlight, click Field.



Units

Click the series you want Works to create.
To                                                          Click  
Create a series of numbers Number
Create a series of dates, including Day
Saturdays and Sundays
Creates a series of dates, excludingWeekday
Saturdays and Sundays
Create a series of months Month
Create a series of years Year
Notes:

If the starting value is text, the Number option is unavailable.
If the starting value is a number other than a date, the Day, Weekday, Month, and Year options are 

unavailable.



Step By

Type a number to determine the increment for the series.    Works proposes 1.
For example, if you type 5 and have entered a starting value of 100, Works creates this series: 100, 105, 110, and
so on.



Name

To rename a highlighted field, type a name up to 15 characters long.    Do not type a colon at the end of the
name.



Width

To specify field width in number of characters, type a number between 0 and 79.
Note:    The maximum width may vary depending upon the font and font size you are using.



Row

To delete the row in which the highlight is located, click Row.



Column

To delete the column in which the highlight is located, click Column.



Row

To insert a row above the position of the highlight, click Row.



Column

To insert a column to the left of the highlight, click Column.



Type
Lists row types you can insert in your report definition.

Click the row type you want to insert.
To insert a row                                      Click  
That prints once at the beginning of Title
your report where you can type
a title or other text
That prints at the top of every pageHeadings
where you can type headings
for fields in your report
That prints before each group Intr Fieldname
of related records where you can 
type headings for each group.    
This choice is only available if you 
have sorted the records.
Where you can type instructions that Record
tell Works what fields to include
in the report.
That prints after each group Summ Fieldname
of related records where you can 
include summary information for
each group.    This choice
is only available if you 
have sorted the records.
That prints once at the end of your Summary
report where you can add summary
statistics.



Fields
Lists the fields in the current report.

Click the field name you want to insert.    If you can't see all of the available names, click the up or down 
arrow.

Works inserts the field name at the position of the highlight 
( ).    Most often you insert a field name in the Headings row.



Fields
Lists the fields in the current report.

Click the field you want to include in your report.    If you can't see all of the available names, click the up 
or down arrow.

Works inserts the instruction, for example, =Last name, at the position of the highlight ( ).    Most often you 
insert a field instruction in the Record row.



Fields
Lists the fields within your report.

Click the field you want the statistic to apply to, then click the statistic you want to apply in the Statistic 
box.

Works inserts the formula, for example, =SUM(Cost), at the position of the highlight ( ).    Most often you insert 
a summary statistic in a Summary row.



Statistic
Lists the seven functions you can use in a report to create summary statistics.

To add statistics to the end of your report, choose a field from the Fields In Report box, and then click the 
function you want to apply to the field.

To                                                             Click  
Total entries in a numeric field SUM
Average entries in a numeric field AVG
Count the number of entries in a field COUNT
Find the smallest value in a numeric field MIN
Find the largest value in a numeric field MAX
Calculate the standard deviation STD
in a numeric field
Calculate the variance in a numeric field VAR



1st Field
1 Type the name of the most significant field you want Works to sort by.

Works sorts by the 1st Field first, and by a second and third field only if two or more records share the same 
information in the first sort field.

2 Choose Ascending or Descending.

To organize the record in ascending order (0-9 and from A-Z ), click Ascend.
To organize the record in descending order (Z-A and from 9-0), click Descend.

3 Choose Break if you want to separate the entries into groups each time information in the sort field changes.
When you "break" on a sort field, Works groups similar records together and inserts a summary row at the end of 
each group that contains subtotals.

4 Choose 1st Letter if you want Works to group entries according to the first letter in the field.
For example, choosing 1st Letter groups all of the field entries that start with the letter "A," all that start with "B," 
and so on.    If you do not choose 1st Letter, Works creates groupings whenever there is a change in any part of an
entry in the sort field.



2nd Field
1 Type the field you want Works to sort by if entries in the first sort field are the same.
2 Choose Ascending or Descending.

To organize the record in ascending order (0-9 and from A-Z ), click Ascend.
To organize the record in descending order (Z-A and from 9-0), click Descend.

3 Choose Break if you want to separate the entries into groups each time information in the sort field changes.
When you "break" on a sort field, Works groups similar records together and inserts a summary row at the end of 
each group that contains subtotals.

4 Choose 1st Letter if you want Works to group entries according to the first letter in the field.
For example, choosing 1st Letter groups all of the field entries that start with the letter "A," all that start with "B," 
and so on.    If you do not choose 1st Letter, Works creates groupings whenever there is a change in any part of an
entry in the sort field.



3rd Field
1 Type the field you want Works to sort by if entries in the second sort field are the same.
2 Choose Ascending or Descending.

To organize the record in ascending order (0-9 and from A-Z ), click Ascend.
To organize the record in descending order (Z-A and from 9-0), click Descend.

3 Choose Break if you want to separate the entries into groups each time information in the sort field changes.
When you "break" on a sort field, Works groups similar records together and inserts a summary row at the end of 
each group that contains subtotals.

4 Choose 1st Letter if you want Works to group entries according to the first letter in the field.
For example, choosing 1st Letter groups all of the field entries that start with the letter "A," all that start with "B," 
and so on.    If you do not choose 1st Letter, Works creates groupings whenever there is a change in any part of an
entry in the sort field.



Width

To specify column width in number of characters, type a number between 0 and 79.
Note:    The maximum width may vary depending upon the font and font size you are using.



Number of Copies

Type the number of copies of your database or report you want to print.
For example, if you type 3 and your database is three pages long, Works will print nine pages altogether.



Print Range

To print the entire database or report, click All.
--Or--

To print a range of pages, click Pages, and then type the page numbers in the From and To boxes.



Draft Quality Printing

Click to print your document without bold, italic, and underline formatting.    An "X" appears in the box 
when this option is chosen.

Depending on your printer, Works may print faster with Draft Quality Printing chosen.



OK

To carry out the choices you've made and print the current document, click OK or press ENTER.



Shortcuts...

On the Toolbar, click...

--or--
Press CTRL+P



Print Gridlines
Gridlines are the lines used in list view to divide your database into a grid of rows and columns.

Click to print the gridlines.    An "X" appears in the box when this option is chosen.



Print Record and Field Labels

Click to print record and field labels.    An "X" appears in the box when this option is chosen.



Print All but Record Rows

Click to print all information in a report except the field entries.    An "X" appears in the box when this 
option is chosen.

Works prints the report title, headings, and summary rows, but does not include any of the field entries in the 
report.



To create a report
1 On the Toolbar, click the Report button

--or--
From the View menu, choose Create New Report.

2 Type the title you want for the report.

3 Choose the field you want to appear in the left column of your report.

Note:    The order you choose the fields determines the order they print from left to right.
4 Choose Add.
5 Repeat steps 3 and 4 until you have added all the fields you want to include in your report.
6 Choose OK.

Works displays the Report Statistics dialog box.
7 If you want Works to calculate any information for you, choose the field you want the calculation to apply to.

8 Choose the statistics you want Works to calculate for the field.

Note:    The seven statistical functions listed are the only functions you can use in a report.
9 To specify calculations for other fields, repeat steps 7 and 8.
10 Works proposes that the statistics be positioned together in rows, one after the other.    If you want to position 

each statistic under its column, choose Under Each Column.

11 Choose OK.
Works displays a message telling you that you have created a report.

12 To view the report definition, choose OK.

To see what the report will look like when you print it, choose the Preview button on the Toolbar.

To print the report, choose the Print button on the Toolbar.

To create a report from scratch, do not choose any fields to include in the report; then choose OK.    Works 
displays a blank report definition.    You can then type a title for the report, the names of the fields you want to 
include in the report, and so on.    For information on report definition view, see    

 Changing a report.



To name a report
1 From the View menu, choose Name Report.

Works lists all exisiting reports.
2 Choose the report you want to rename.

3 Type a new name, up to 15 characters long.

4 Choose Rename.
5 To rename another report, repeat steps 2 through 4.
6 Choose OK.

Works displays the new name on the View menu.



To move in report definition view using the mouse

To move to an entry, click the one you want.
To move up or down within a report definition, use the vertical scroll bar.

To move left or right within a report definition, use the horizontal scroll bar.



To move in report definition view using the keyboard
To move                   Press  
Right one space
Left one space
Down one row
Up one row
Next column TAB

Previous column SHIFT+TAB

Start of a row HOME

Last entry in a row END

Down one window PAGE DOWN

Up one window PAGE UP

Right one windowCTRL+PAGE
DOWN

Left one window CTRL+PAGE UP

Beginning of report CTRL+HOME

End of report CTRL+END

Up to the next CTRL+
group of entries
Down to the next CTRL+
group of entries
Left to the next CTRL+
group of entries
Right to the next CTRL+
group of entries



To quickly change the column width in report definition view
1 Move the mouse pointer () to the border at the right of the column heading.

When you have it in the right place, the pointer changes shape.

2 Drag to the right or left until the column is the width you want.
To set an exact column width
1 Highlight the column whose width you want to change.
2 From the Format menu, choose Column Width.
3 Type the number of characters you want to display (0-79).

4 Choose OK.



To highlight an entry in report definition view

Click the entry.

Press the arrow keys () until you move the highlight () to the entry.



To highlight several entries in report definition view

1 Move the pointer () to the upper-left corner of the group you want to highlight.
2 Drag until you highlight the entry in the lower-right corner of the group.

To cancel a selection, click anywhere in the window.

1 Press the arrow keys () until you move the highlight () to the upper-left corner of the group.
2 Hold down SHIFT and press the arrow keys to extend the selection.

To cancel a selection, press an arrow key or press ESC.
--Or--

1 Press the arrow keys until you move the highlight to the upper-left corner of the group.
2 From the Select menu, choose Cells.

--or--
Press F8.
EXT is displayed in the status bar.

3 Press the arrow keys to extend the selection.
To stop extending the selection, press ESC.    To cancel the entire selection, press ESC again. 



To highlight a column in report definition view

Click the column letter.    For example, click A.
To highlight several adjacent columns, move the pointer () to the leftmost column and then drag to the right.
To cancel a selection, click anywhere in the report definition.

1 Press the arrow keys () until you move the highlight
() to the column.
To highlight several adjacent columns, move the highlight to the leftmost column; then hold down SHIFT and 
press    until you highlight an entry in each column you want to include in the selection.

2 From the Select menu, choose Column.
--or--
Press SHIFT+F8.
To cancel a selection, press ESC.



To highlight a row in report definition view

Click the row label.    For example, click Title.
To highlight several adjacent rows, move the pointer () to the uppermost row label and then drag down.
To cancel a selection, click anywhere in the report definition.

1 Press the arrow keys () until you move the highlight () to the row.
To highlight several adjacent rows, move the highlight to the uppermost row; then hold down SHIFT and press    
until you highlight an entry in each row you want to include in the selection.

2 From the Select menu, choose Row.
--or--
Press CTRL+F8.
To cancel the selection, press ESC.



To highlight the entire report definition

Click the button above the first row.

To cancel the selection, click anywhere in the report definition.

From the Select menu, choose All.
--or--
Press CTRL+SHIFT+F8.

To cancel the selection, press ESC.



To edit part of an entry in report definition view
1 Highlight the entry you want to change.

The entry is displayed in both the report definition and in the formula bar.
2 Press F2 or click in the formula bar.

A blinking insertion point is displayed in the formula bar.
3 Move the insertion point to the place you want to edit.
4 To delete a character to the left of the insertion point, press BACKSPACE.

--Or--
To delete a character to the right of the insertion point, press the DEL key.

5 Type any new text you want.
If you decide not to replace the entry, press ESC or click the Cancel box in the formula bar.

6 Press ENTER or click the Enter box in the formula bar.



To replace an entry in report definition view.
1 Highlight the entry you want to replace.

The entry is displayed in both the report definition and in the formula bar.
2 Type the new entry.

As you type, the new text replaces the old entry.
If you make a mistake, press BACKSPACE.

If you decide not to replace the entry, press ESC or click the Cancel box in the formula bar.
3 Press ENTER or click the Enter box in the formula bar.



To add an entry in report definition view
1 Move the highlight to the place where you want the entry to appear.

If you want to enter the information between existing entries, insert a row or column first.
2 Type the entry.

As you type, the entry is displayed in both the report definition and in the formula bar.
If you make a mistake, press BACKSPACE.
If you decide not enter the information, press ESC or click the Cancel box in the formula bar.

3 Press ENTER or click the Enter box in the formula bar.

I can't see all of the entry?
The column is not wide enough to display the entire entry.    Just change the column width.



To insert a column in report definition view
1 Highlight the column you want to appear to the right of the new column.

To insert more than one column, highlight more than one.    As many columns as you highlight will be inserted.
2 From the Edit menu, choose Insert Row/Column.

Works inserts a blank column to the left of the one you highlight.



To insert a row in report definition view
1 Highlight the row you want to appear below the new row.

If you want to insert more than one row of the same type, highlight more than one row.    As many rows as you 
highlight will be inserted.

2 From the Edit menu, choose Insert Row/Column.
3 Choose the row type you want to insert.

Note:    Works groups rows of the same type together and always keeps row types in the same order in the report
definition.
If you choose a different row type than the row you highlighed, Works inserts the row with others of the same 
type.

4 Choose OK.
Works inserts the new row.



To delete an entry in report definition view
1 Highlight the entry or entries you want to delete.
2 From the Edit menu, choose Cut

--or--
Press CTRL+X.

If you delete an entry by mistake using the Cut command, you can reinsert it if you choose Paste before you 
choose Cut or Copy again.



To clear an entry in report definition view
Important:    There is no way to recover cleared information.
1 Highlight the entry or entries you want to clear.
2 From the Edit menu, choose Clear.

Works clears the information.

If you only want to clear one entry, you can highlight it and then press the DEL key.



To move an entry in report definition view
Important:    If you move the information to a location that already contains entries, the moved information replaces 
the existing entries.    To avoid this, you can insert blank columns or rows first.
1 If necessary, insert a blank row or column where you want to move the information.
2 Highlight the entry or entries you want to move.
3 From the Edit menu, choose Cut.

--or--
Press CTRL+X.

4 Highlight the upper-left corner of the area you want to move the information to.
5 From the Edit menu, choose Paste.

--or--
Press CTRL+V.

When you choose the Cut command, Works places the information on the Clipboard.    You can then paste that 
information as many times as you like until you cut or copy other information to the Clipboard.



To copy an entry in report definition view
Important:    When you copy information to a location that already contains entries, the copied information replaces 
the existing entries.    To avoid this, you can insert blank fields or records first.
1 If necessary, insert a blank row or columnwhere you want to place the copied information.
2 Highlight the entry or entries you want to copy.
3 From the Edit menu, choose Copy.

--or--
Press CTRL+C.

4 Highlight the upper-left corner of the area you want to copy to.
5 From the Edit menu, choose Paste.

--or--
Press CTRL+V.

When you choose the Copy command, Works places the information on the Clipboard.    You can then paste that
information as many times as you like until you cut or copy other information to the Clipboard.



To open an existing report
1 If you have not already done so, open or switch to the database where you created the report.
2 From the View menu, choose the name of the report you want to open.



To delete a column or row in report definition view
Important:    There is no way to recover deleted information.
1 Highlight the entire column or row you want to delete.

You can highlight as may adjacent columns or rows as you want to delete.
2 From the Edit menu, choose Delete Row/Column.



To insert a field name as a heading or label
1 Move the highlight to the place where you want to insert the field name.
2 From the Edit menu, choose Insert Field Name.
3 Choose the field name you want to insert.

4 Choose OK.
Works inserts the field name.

If you want to type a field name instead of inserting it, move the highlight to the location where you want to type
the name of the field, type it, and then press ENTER.



To add a continuous line to your report
1 Move the highlight to a blank row where you want the line displayed.
2 Press the key for the character you want to use in the line.    Repeat until the line is as long as you want it.

For example, if you use the period (.) key, your line will look like this:    .................
Note:    If you want to use the minus symbol (-), type a quotation mark
(") first so that Works will interpret the entry as text rather than as an operator in a formula.
If you decide not enter the line, press ESC or click the Cancel box in the formula bar.

3    Press ENTER or click the Enter box in the formula bar.

If you want to see what the line will look like before you print, click the Preview button on the Toolbar.



To insert a field entry
1 Move the highlight to the place where you want to insert the entry.
2 From the Edit menu, choose Insert Field Entry.
3 Choose the field whose entries you want to include in the report.

4 Choose OK.
Works inserts an equal sign (=) and the field name you chose, for example, =Item.
When you print the report, Works prints the field's entries in that column.

If you want to type a field entry instruction instead of inserting it, move the highlight to the location where you 
want to type the instruction; then type an equal sign
(=) followed by the field name.
Example:      =Item



To insert a field summary instruction
1 Move the highlight to the place where you want to insert the instruction.
2 From the Edit menu, choose Insert Field Summary.
3 Choose the name of the field you want to apply the statistic to.

4 Choose the statistic you want to apply to the field.

5 Choose OK.
Works inserts an equal sign, the statistical function, and the field name you chose, for example, =(SUM) Item.
Note:    The seven statistical functions listed are the only functions you can use in a report.

If you want to type a summary instruction instead of inserting it, move the highlight to where you want to type 
the instruction; type an equal sign (=), the statistic, and then the field name enclosed in parentheses.
Example:      To average the values of entries in the Cost field, type =AVG(Cost)



To sort records and add breaks in report definition view
1 From the Select menu, choose Sort Records.
2 Under 1st Field, type the name of the most important field you want to sort by.

For example, if you are sorting a list of names, the most important field is the last name field, the second most 
important field is the first name field, and the third most important field is the middle name or initial field.

3 Choose either Ascend (A-Z or 0-9) or Descend (Z-A or 9-0).
4 If you want to separate one group from the next, choose Break.
5 If you want Works to group entries according to the first letter in the field, choose 1st Letter.

For example, choosing 1st Letter groups all of the field entries that start with the letter "A," all that start with 
"B," and so on.    If you do not choose 1st Letter, Works creates groupings whenever there is a change in any part
of an entry in the sort field.

6 To sort or break on a second field, repeat steps 2 through 5 for the options under 2nd Field.
7 To sort or break on a third field, repeat steps 2 through 5 for the options under 3rd Field.
8 Choose OK.

For each field that you break on, Works adds a summary row to your report definition.    Works automatically 
determines a subtotal for each field in the group.    For fields that contain numbers, Works uses the SUM 
function.    For fields that contain text, Works uses the COUNT function. 
You can delete any of these subtotals or use any of the other statistical functions (AVG, MAX, MIN, STD, VAR).

To sort by more than three fields, sort the database twice.    For example, if you want your records to be 
organized by Zip Code, city, last name, first name, and then middle initial, you:

First sort by the three least important fields.    Of those three fields, use the most important field as the 1st 
Field (Last name), the next as the 2nd Field (First name), and the least important as the 3rd Field (Middle initial).

Then sort the remaining fields, again using the most important field as the 1st Field (ZIP Code) and the 
next most important field as the 2nd field (City).

To make sure the records are organized as you want them before you print, click the Preview button on the 
Toolbar.

If you switch to form view or list view, the records are organized the same way as the last report you sorted. If 
you want to change the sort order back to the way it was before you sorted your report, choose the Sort Records
command from the Select menu and then choose OK.    



To insert an introductory row in report definition view
1 Highlight the record row.

If you want to insert more than one introductory row, highlight more than one row.    As many rows as you 
highlight will be inserted.

2 From the Edit menu, choose Insert Row/Column.
Works list the different row types you can insert.

3 Choose the introductory row you want to insert, for example, Intr Dept.
4 Choose OK.

Works inserts the introductory row above the record row.    Information in an introductory row prints before each 
group of records.



To duplicate a report
1 From the View menu, choose Duplicate Report.
2 From the list of reports, choose the one you want to duplicate.

3 Type a name for the duplicate.

4 Choose Duplicate.
Works duplicates the report, gives it the name you specified, and adds the name to the View menu.

5 If you want to duplicate another report, repeat steps 2 through 4.
6 Choose OK.



To delete a report
Important:    There is no way to recover deleted information.
1 From the View menu, choose Delete Report.
2 From the list of reports, choose the one you want to delete.

3 Choose Delete.
4 If you want to delete another report, repeat steps 2 and 3.

5 Choose OK.
If you delete all the reports for a database, Works returns to the view you were working in before you switched 
to report definition view.



To change the font and size in report definition view
1 On the Toolbar, click the down arrow to display the available fonts. 

2 Click the font you want.
3 On the Toolbar, click the down arrow to display the available point sizes.

4 Click the point size you want.
--Or--
1 From the Format menu, choose Font.
2 Under Font, choose the font you want.

3 Under Size, choose the point size you want.
4 Choose OK.



To change the style in report definition view
1 Highlight the entries whose style you want to change.
2 On the Toolbar, click the style you want.

--or--
To apply                     Press  
Bold CTRL+B
Italic CTRL+I
Underline CTRL+U

--Or--
1 Highlight the entries whose style you want to change.
2 From the Format menu, choose Style.
3 Choose the styles you want.

4 Choose OK.

To apply the same styles to other entries, highlight the entries; then press SHIFT+F7.
To remove all styles, highlight the entries; then press CTRL+SPACEBAR.



To quickly change the alignment in report definition view
1 Highlight the entries whose alignment you want to change.
2 On the Toolbar, click the alignment you want.

--or--
To align                      Press  
Left CTRL+L
Center CTRL+E
Right CTRL+R

To change the alignment and apply other styles
1 Highlight the entries whose alignment and styles you want to change.
2 From the Format menu, choose Style.
3 Under Alignment, choose the option you want.

4 Under Styles, choose the styles you want.
5 Choose OK.

To apply the same alignment or styles to other entries, highlight the entries; then press SHIFT+F7.



To insert a page break in report definition view
1 To insert a horizontal page break, highlight the row you want to appear below the page break.

To insert a page break here...

--Or--
To insert a vertical page break, highlight the column you want to appear to the right of the page break.
To insert a page break here...

2 From the Edit menu, choose Insert Page Break.
Works inserts the page break and automatically adjusts all other page breaks.



To delete a page break in report definition view
1 To delete a horizontal page break, highlight the row below the page break.

To delete a page break here...

--Or--
To delete a vertical page break, highlight the column to the right of the page break.
To delete a page break here...

2 From the Edit menu, choose Delete Page Break.
Works deletes the page break and adjusts all remaining page breaks.



To print a report
1 If you want to print a summary report--one that contains only the title, headings, and summary information--

choose Page Setup & Margins from the File menu.    Choose Print All But Record Rows.
2 On the Toolbar, click the Print button.

--or--
From the File menu, choose Print.
--or--
Press CTRL+P.

3 If you want to print more than one copy, type the number of copies you want.

4 If you want to print only part of the report, choose the Pages option and then type the range of page numbers 
you want to print.

5 If you want Works to print without bold, italic, and underline formatting, choose Draft Quality Printing.

6 Choose OK.

You can see the page numbers for your report in the preview window.    To preview a document, click the Preview 
button on the Toolbar.



To copy a report
1 From the View menu, choose the name of the report you want to copy.
2 From the Edit menu, choose Copy Report Output.
3 Open or switch to the file you want to copy to.
4 Move the insertion point or highlight to the location you want to copy to.
5 From the Edit menu, choose Paste.

--or--
Press CTRL+V.

If you copy to the Word Processor, you may need to adjust tabs, fonts, and font sizes to properly display 
the copied information.

If you copy to the Spreadsheet, you may need to adjust the column width to properly display the copied 
information.

I copy to the Word Processor but do not see any tab stops or paragraph marks?
Choose the Show All Characters command from the Options menu.



To create a header or footer
1 From the Edit menu, choose Headers & Footers.
2 Type the text and any header and footer codes you want (see table below).

For example, to left align the header "Customers," type...

...or type this to have Works automatically insert the page number as a footer.
3 Choose OK.

Header and footer codes
To                               Type  
Print the page &p
number
Print the date in &d
short format
Print the date in &n
long format
Print the time &t
Print the filename &f
Left-align text &l
Center text &c
Right-align text &r
Print & (ampersand) &&

To see what a header or footer looks like before you print or to check its position on the page, click the 
Preview button on the Toolbar.

When you insert a date or time in a header or footer, it is displayed as 6/8/92 (short form), June 8, 1992 
(long form), or 2:30 PM (12-hour clock).    This may vary depending on the country you selected when you first 
installed Windows.

For more information, see  Changing the International Settings



To change the starting page number
1 From the File menu, choose Page Setup & Margins.
2 Type the number you want Works to use as the starting page number.

3 Choose OK.

I don't see any page numbers on my printed document?

You need to create a header or footer that tells Works to insert the page number.    For more information, see    
How to Create a Header or Footer.



To adjust the header or footer margin
1 From the File menu, choose Page Setup & Margins.
2 Type a new measurement for any of the margins you want to change.

Works assumes the unit of measure is inches--you don't have to type the inch symbol (").

The header margin must be smaller than your document's top margin and the footer margin must be smaller 
than the bottom margin.

3 Choose OK.

If you want to enter another unit of measure, type the abbreviation after the measurement.    For example, 
type cm for centimeters, pi for picas, or pt for points.

For information on changing the preset unit of measure, see     How to Change the Unit of Measure.

If you want to check the header or footer position on the page before you print, click the Preview button on
the Toolbar.



To print without a header or footer on the first page
1 From the Edit menu, choose Headers & Footers.
2 Choose the options you want.

3 Choose OK.



To delete a header or footer
1 From the Edit menu, choose Headers & Footers.
2 In the Header or Footer box, highlight the text you want to delete.

3 Press the DEL key.
4 If necessary, repeat steps 2 and 3 to delete text in the other box.
5 Choose OK.



To adjust page margins
1 From the File menu, choose Page Setup & Margins.
2 Type a new measurement for any margin you want to change.

Works assumes the unit of measure is inches--you don't have to type the inch symbol (").

The header margin must be smaller than the top margin and the footer margin must be smaller than the bottom 
margin.

3 Choose OK.

If you want to enter another unit of measure, type the abbreviation after the measurement.    For example, 
type cm for centimeters, pi for picas, or pt for points.

For information on changing the preset unit of measure, see     How to Change the Unit of Measure.

If you want to see what the margins look like before you print, click the Preview button on the Toolbar.



To change the page size
1 From the File menu, choose Page Setup & Margins.
2 Type a new measurement for the page length or width.

Works assumes the unit of measure is inches--you don't have to type the inch symbol (").

Note: If you want to print on legal paper, change the page length to 14".
3 Choose OK.
4 From the File menu, choose Printer Setup.
5 To print on paper other than 8.5" by 11", click the arrow and choose the paper size you want.

6 Choose OK.
Note:    When you change the page size in the Printer Setup dialog box, you change it for all documents and 
applications.
For example, if you change to legal-size paper (8.5" by 14"), but then want to print a document on letter-size 
paper (8.5" by 11"), you need to:
1 Make sure the page length and width settings are correct in the Page Setup & Margins dialog box.
2 Change the paper size back to letter size (8.5" by 11") in the Printer Setup dialog box.
If you forget to do this, Works will give you a message before you print.



To change the page orientation
1 From the File menu, choose Page Setup & Margins.
2 To change the page orientation, switch the measurements.

For example, to print horizontally on 8.5" by 11" paper, change the length to 8.5" and the width to 11".
Works assumes the unit of measure is inches--you don't have to type the inch symbol (").

3 Choose OK.
4 From the File menu, choose Printer Setup.
5 Under Orientation, choose Portrait or Landscape.

If you choose Landscape orientation, it may affect the way all your documents look.    See the Notes section 
below for more information.

6 Choose OK.
Notes:

When you change the orientation in the Printer Setup dialog box, you change it for all documents and 
applications.

For example, if you change the orientation to landscape but then want to print a document in portrait 
orientation, you need to:
1 Change the page length and width in the Page Setup & Margins dialog box.
2 Change the orientation back to Portrait in the Printer Setup dialog box.
If you forget to do this, Works will give you a message before you print.

When you change to landscape orientation, there are only certain fonts that are available for printing.    
This may temporarily change the way all your documents look.

For example,if you print your database and then want to print a word processor document using other fonts, you
need to change back to portrait orientation to see those fonts again.



To preview a document
1 On the Toolbar, click the Print Preview button

--or--
From the File menu, choose Print Preview.
Works displays the document in the print preview window.

2 To

See the next page, choose Next. 
See the previous page, choose Previous.
Magnify the page half way, choose Zoom In.
Move from one part of the magnified page to another, use the scroll bars

--or--
Press PAGE UP or PAGE DOWN.

Magnify the page all the way, choose Zoom In twice.
Return to the full page, choose Zoom Out once or twice depending on how many times you magnified the 

page.
Print the document, choose Print.
Leave print preview, choose Cancel.

When you move the mouse pointer over the page it changes to a magnifying glass.    You can then click the page
to zoom in or out.



To define a query
1 To switch to query view, click the Query button on the Toolbar.

--or--
From the View menu, choose Query.
Works displays a form that looks just like the form you created in form view, except that the word "QUERY" is 
displayed in the status bar.

2 Move the insertion point to first field you want to query.
3 Type the instructions.    The "What do I type?" section of the Querying topic provides examples and information 

for defining queries.
If you make a mistake, press BACKSPACE.

4 Press ENTER.
5 Repeat steps 2, 3, and 4 until you have entered instructions in all the fields you want.
6 To apply the query, switch to form or list view by clicking either the Form View or List View button on the Toolbar.

Works displays only those records that match the conditions you have defined.

Although you can view the results of a query in either form or list view, in list view you can see more than one 
matching record at a time.

I see the message, "No match found"?
Works did not find any records that match the instructions you entered. In this case, Works displays all the 
records.



To reapply the last query

From the Select menu, choose Apply Query.
--or--
Press F3.



To edit an instruction in query view
1 If you have not already done so, switch to query view.
2 Highlight the instruction you want to edit.

The entry is displayed in the formula bar.
3 Press F2 or click in the formula bar.

A blinking insertion point is displayed in the formula bar.
4 Move the insertion point to the place you want to edit.
5 To delete a character to the left of the insertion point, press BACKSPACE.

--Or--
To delete a character to the right of the insertion point, press DEL.

6 Type any new text you want.
7 Press ENTER    or click the Enter box in the formula bar.



To replace an instruction in query view
1 If you have not already done so, switch to query view.
2 Highlight the instruction you want to replace.

The entry is displayed in the formula bar.
3 Type the new entry.

As you type, the new information replaces the old entry.
If you make a mistake, press BACKSPACE.

4 Press ENTER or click the Enter box in the formula bar.



To clear an instruction in query view
1 If you have not already done so, switch to query view.
2 Highlight the instruction you want to clear.
3 From the Edit menu, choose Clear Field Entry.

--or--
Press the DEL key.

4 Press ENTER.



To delete the entire query
1 If you have not already done so, switch to query view.
2 From the Edit menu, choose Delete Query.



Active
The active window or document is the one you are currently working in.    There can only be one active window or 
document at a time.



ANSI character set
The American National Standards Institute 8-bit character set which contains 256 characters.    This character set is 
used by Windows and supported by some Windows applications.



Argument
Values that you supply for a function to use in its calculations such as field names or numbers.    Most Works 
functions use one or more arguments.



Ascending order
Entries are organized alphabetically from A-Z or numerically from 0-9.    Works sorts text entries first, followed by 
numbers, and then blanks.
If a field contains mixed entries (such as addresses that contain numbers and text), Works places mixed entries that
begin with numbers ahead of mixed entries that begin with text.



AVG (Average)
Averages entries in a numeric field.



Clipboard
A temporary storage area for cut or copied information. You can paste the contents of the Clipboard into another 
part of your database, another Works document, or another Windows application.



Comma format



Constant value
A value you type in a field, such as a number, date, or time.    Unlike values resulting from formulas, constant values
are not subject to change.



COUNT
Counts the number of entries in a field.



Currency format



Database title bar
Displays the name of the database.    Drag the title bar to move the window.



Date
You can enter dates into fields and use them in formulas.    When you type a date, use any of the formats Works 
recognizes.

When you type a date using a format Works recognizes, Works stores it as a number.    You can then use the date in 
a formula to determine elapsed time.



Descending order
Entries are organized alphabetically from Z-A or numerically from 9-0.    Works sorts numbers first, followed by text, 
and then blanks.
If a field contains mixed entries (such as addresses that contain numbers and text), Works places mixed entries that
begin with text ahead of mixed entries that begin with numbers.



End-of-line mark    
In form view, when you are typing information in a field that is more than one line high, you need to press 
SHIFT+ENTER to move to the next line.
When you press SHIFT+ENTER, Works inserts an end-of-line mark to indicate the end of the first line.



Exponential format



Field
A category of information, such as Last name or First name.

The term "field" refers to both the field name and the entries.    In form view, you can only see one entry at a time.



Field
A category of information, such as Last name or First name.

The term "field" refers to both the field name and the entries.



Field
A category of information, such as Last name or First name.    The term "field" refers to both the field name and the 
entries.



Field lines
Field lines are the dotted lines that appear beneath field entries in form view.



Filename
Filenames can contain up to eight characters.    You can use any characters except for spaces and those shown 
below, which have a special meaning for DOS.

When you save a document, Works automatically adds a three letter extension to the filename to help you identify 
the type of document.    Works adds the extension .WPS to a Word Processor document, .WKS to a spreadsheet, 
or .WDB to a database..



Fixed format



Font
A set of characters with a specific design; also called a typeface or typestyle. Each font has a name, for example, 
Courier or Helv.    Each font has one or more sizes (measured in points) to choose from.



Footer
Text that prints at the bottom of every page.    For example, you may want to use a footer to add page numbers or 
the current date or time to each page of your printed document.



Footer margin
The space between the bottom edge of the paper and the first line of footer text.    The footer margin must be 
smaller than the document's bottom margin.



Format
Refers to the way entries look within a field.    The format includes the alignment (general, left, right, center), styles 
(bold, italic, underline), and the way dates, times, and numbers are displayed.    Format changes apply to all entries 
in a field.



Formula
An equation Works uses to calculate a field's value.    Formulas can contain numbers, field names, operators (such 
as +, *, -, /), and functions.    When you type a formula, start with an equal sign (=).



Formula bar



Form view
Displays information one record at a time.



Function
A built-in calculation you can use in a formula.    For example, in the formula =AVG(Sales), Works computes the 
average value of the numbers in the Sales field using the AVG function.    You do not need to manually add or count 
the values in the field to find the average; Works does this for you.



General format



Gridlines
Lines used in list view to divide your database into a grid of rows and columns.

To hide or display the gridlines, choose the Show Gridlines command from the Options menu.
To print with gridlines, choose Page Setup & Margins from the File menu, then click the Print Gridlines 

check box 



Header
Text that prints at the top of every page. For example, you may want to use a header to add page numbers, a title, 
or a date to each page of your printed document.



Header margin
The space between the top edge of the paper and the first line of header text.    The header margin must be smaller 
than the document's top margin.



Horizontal scroll bar
In form view, use to move left or right within a large form.



Horizontal scroll bar
In list view, use to move from one field to another.



Horizontal scroll bar
Use to move left or right within a report definition.



Label
Any descriptive text you add in form view, such as titles or instructions for filling out a form.

You can only add labels in form view--they do not appear in list view.



Label
Any descriptive text you add in form view, such as titles or instructions for filling out a form.    You can only add 
labels in form view--they do not appear in list view.    Note:    A label is different than a field name.



Leading zeros format



List view
Displays several records at once.



MAX (Maximum)
Finds the largest number in a numeric field.



Menu bar
Displays the menu names for an application.    The names that are displayed depend on the type of document you 
are working on.

To open a menu where you can see a list of choices, click the menu name on the menu bar.



MIN (Minimum)
Finds the smallest number in a numeric field.



Non-proportional font
A font in which all characters have the same width.

Non-proportional fonts are also referred to as fixed-pitch fonts.    For example, "10 pitch" means 10
characters per inch; each character is 1/10 of an inch wide.



Number
A number can be entered directly in a field or produced as the result of a formula. You can apply various formats to 
numbers such as:

Note:    When you enter a date or time in a format Works recognizes, Works stores the date or time as a number.



Number format
Refers to the way numbers are displayed within a field.    Possible number formats include displaying numbers as 
percentages, in exponential notation, or with currency symbols and commas.



Operators
You can use operators in a formula to specify an operation, such as addition or multiplication. Works recognizes 
these operators: + (addition), - (subtraction), * (multiplication), / (division), - (negative), + (positive), ^ 
(exponential), = (equal to).



Percent format



Proportional font
A font in which the width of each letter varies depending on the character.    For example a "w" is wider than an "i".   
However, the width of numbers does not vary so that they will still line up exactly when you print your database.



Record
All the information about one person, product, event, and so on.

For example, in an address list a record would include all the information about one person, such as their last name,
first name, street, city, state, and Zip Code.



Record
All the information about one person, product, event, and so on.

For example, in an address list a record would include all the information about one person, such as their last name,
first name, street, cty, state, and Zip Code.



Record
All the information about one person, product, event, and so on.    For example, in an address list a record would 
include all the information about one person, such as their last name, first name, street, city, state, and Zip Code.



Record and field headings
Record headings are the numbers that identify each record.    Field headings are the field names that identify each 
column.



Record buttons
Located in the lower-left corner of your form.    Click to move from one record to another.



Record buttons
Click to move from one record to another.



Row types
If you want to add                  Choose  
A row that prints at the Title row
beginning of your report
A row that prints at the top Heading row
of every page
A row where you can type Record row
instructions that tell
Works what fields to
include in the report
A row that prints at the Summary row
end of your report
Note:    If you have added a break to a field, you can also add an Introductory or Summary row for the field.    An 
Introductory row prints before each group of records.    A Summary row prints at the end of each group of records.



Scroll bar
Use to move within a document.
To move                                     Do this  
One line or space at a time Click an arrow
One window at a time Click before or after the box
To a general location Drag the box



Split bar
Drag to the right to divide a window vertically.



Split bar
Drag down to divide a window horizontally.



Statistic
To                                Choose  
Total all entries in Sum
a numeric field
Average all values Average
in a numeric field
Count the number of Count
entries in a field
Find the smallest Minimum
number in a 
numeric field
Find the largest Maximum
number in a
numeric field
Calculate the Standard Deviation
standard deviation
in a numeric field
Calculate the Variance
variance for a
a numeric field



Status bar
An area at the bottom of the Works window that displays messages and command descriptions.

If the status bar is not displayed, choose Works Setting from the Options menu, and then choose the Show Status 
Bar check box.



STD (Standard Deviation)
Calculates the standard deviation for a numeric field.



SUM
Totals all entries in a numeric field.



Template
A "sample document" you can create to save time when you want to create several similar documents.    When you 
create a template, each new document you create will have the settings, text, and formats you included in the 
template, until you turn the template off.



Text
Any entry Works does not interpret as a formula or number.    Works inserts a quotation mark before a text entry in 
the formula bar.    The quotation mark only appears in the formula bar, not in the field. The following examples are 
text entries:

If you enter a date or time in a format Works does not recognize, Works stores the entry as text.



Time
You can enter times into fields and use them in formulas.    When you type a time, use any of the formats Works 
recognizes.

When you type a time using a format Works recognizes, Works stores it as a number.    You can then use the time in 
formulas that determine elapsed time.



Toolbar
The row of buttons beneath the menu bar.

Use the Toolbar to quickly:
Change the font, style, and alignment of entries in your database.
Switch between views.
Preview and print your document.
If the Toolbar is not displayed, choose Show Toolbar from the Options menu.



True/false format



VAR (Variance)
Calculates the variance for a numeric field.



Vertical scroll bar
In form view, use to move up and down within a large form.



Vertical scroll bar
In list view, use to move from record to record.



Vertical scroll bar
Use to move up or down within a report definition.



Wildcard
A symbol that can stand for any character or any number of characters.



Works title bar
Displays the name of the application.    Drag the title bar to move the window.



WorksWizard
Automated templates you can use to create form letters, mailing labels, or an address database.    You decide what 
you want to create, Works prompts you for information, then the WorksWizard creates the document for you.



Workspace



Procedure popups



Click
1 Move the mouse pointer over the item you want.
2 Press and quickly release the mouse button.



Double-click
1 Move the mouse pointer over the item you want.
2 Press and release the mouse button twice in quick succession.



Drag
1 Position the mouse pointer over the item you want to move.
2 Hold down the mouse button while you move the mouse.
3 When you reach the location where you want to place the item, release the mouse button.



Drag
1 Hold down the mouse button while you move the mouse.
2 Release the mouse button to complete the action.



To change column width
1 Move the mouse pointer () to the border at the right of the column heading.

When you have it in the right place, the pointer changes shape.

2 Hold down the mouse button and drag to the left or right until the column is the width you want.



To change the field size
1 Click the field entry whose size you want to change.    Example:

2 Move the mouse pointer to the resize handle.
When you have it in the right place, the pointer changes shape.

3 Hold down the mouse button and drag the mouse until the field is the size you want.



To change the field width
1 Move the mouse pointer () to the border at the right of the field name.

When you have it in the right place, the pointer changes shape.

2 Hold down the mouse button and drag the mouse to the left or right until the field is the width you want.



To change the field width

1 Click the field entry whose size you want to change.    Example:

2 Move the mouse pointer to the resize handle.
When you have it in the right place, the pointer changes shape.

3 Hold down the mouse button and drag until the field is the size you want.

1 Move the mouse pointer () to the border at the right of the field name.
When you have it in the right place, the pointer changes shape.

2 Hold down the mouse button and drag to the left or right until the field is the width you want.



To check that all fields are locked
1 If you are not in list view, choose List from the View menu.
2 Highlight the entire database by clicking the button above the first record number.

3 From the Format menu choose Style.

If all fields are locked, an X appears in the check box.    If only some of the fields are locked, the check box 
appears grayed.

4 If only some of the fields are locked, click the check box.    When an X appears in the box, all fields are locked.



To choose a different directory or drive
To choose a different directory, click the Drive icon then double-click the directory or subdirectory you want.

To choose a different drive, click the down arrow to see the list of drives then click the drive you want.

For example, to save a file on a floppy disk, choose drive a:.



To choose a tool
Click the one you want.
--or--
Press ALT+the underlined letter of the tool you want.



To choose an option
Click the one you want.    You can only choose one option at a time.



To choose from a combo box

If you can't see all of the items, click the up or down arrow or drag the scroll box.

To choose the item and complete the command, double-click the item.



To choose from a drop-down list box

If you can't see all of the items, click the up or down arrow or drag the scroll box 

To choose the item and complete the command, double-click the item.



To choose from a list

If you can't see all of the items, click the up or down arrow or drag the scroll box.

To choose the item and complete the command, double-click the item.



To choose from a menu
Click the name of the menu you want to open.
--or--
Press ALT+the underlined letter in the menu name.



To choose a check box
Click each empty check box you want to choose.    

Note:    To clear a check box, click it again.



To clear a check box
Click each check box you want to clear.    A cleared check box is empty.

Note:    To choose a check box, click it again.



To hide a field name
1 Click the field name you want to hide.
2 From the Format menu, choose Show Field Name.

The field name is no longer displayed on your form.
Note:    When a field name is hidden, there is no check mark beside the Show Field Name command.



To highlight a column
Click the column letter.    For example, click A.
To highlight several adjacent columns, move the pointer () to the leftmost column heading; then hold down the 
mouse button and drag to the right.



To highlight a column or row
To highlight                 Do this  
A column Click the column letter
Several columns Move the mouse

pointer to the leftmost
column number and
then drag to the right

A row Click the row label
Several rows Move the mouse

pointer to the
uppermost row
label and then
drag down



To highlight a field
Click the field name.
To highlight several adjacent fields, move the pointer () to the leftmost field name; then hold down the mouse 
button and drag to the right.



To highlight a field name
Click the field name.
--or--
Press the arrow keys () until you highlight the field name.



To highlight a label
Click the label.
--or--
Press the arrow keys () until you highlight the label.



To highlight a label or field name
Click the label or field name.
--or--
Press the arrow keys () until you highlight the label or field name.



To highlight a record
Click the record number.
To highlight several adjacent records, move the pointer () to the uppermost record number; then hold down the 
mouse button and drag down.



To highlight a row
Click the row label.    For example, click Title.

To highlight several adjacent rows, move the pointer ()to the uppermost row label; then hold down the mouse 
button and drag down.



To highlight an entry
Click the entry.
To highlight several adjacent entries, move the pointer () to the upper-left entry; then hold down the mouse 
button and drag until you highlight the entries you want.



To highlight an entry
Click the entry.
In list view, to highlight entries in more than one field, move the pointer () to the leftmost entry; then hold down 
the mouse button and drag until you highlight the entries you want.



To highlight an entry
Click the entry you want.
--or--
To go to the                   Press  
Next entry TAB
Previous entry SHIFT+TAB



To highlight an instruction
Click the instruction you want.
--or--
To go to the                   Press  
Next instruction TAB
Previous instruction SHIFT+TAB



To highlight text
Drag the mouse pointer across the text you want to highlight.
--or--
Press TAB until you highlight the text you want.



To insert a blank field or record
1 Highlight a field or record for each field or record you want to insert.

To highlight            Do this  
A field Click the field name
Several fields Move the mouse pointer

to the eftmost field name
and then drag to the
right

A record Click the record number
Several records Move the mouse pointer

to the uppermost record
number and then
drag down

2 From the Edit menu, choose Insert Record/Field.



To insert a blank record
1 Highlight a record for each record you want to insert.

To highlight            Do this  
A record Click the record number
Several records Move the mouse pointer

to the uppermost record
number and then
drag down

2 From the Edit menu choose Insert Record/Field.



To insert a blank record
1 Move to the record you want to appear after the inserted record.
2 From the Edit menu choose Insert Record.

Works inserts the blank record before the record you moved to in step 1.



To insert a row or column
1 Highlight a row or column for each row or column you want to insert.

To highlight            Do this  
A row Click the row label
Several rows Move the mouse

pointer to the 
uppermost row
label and then
drag down

A column Click the column label
Several columns Move the mouse

pointer to the
leftmost column
label and then
drag to the right

2 From the Edit menu choose Insert Row/Column.



To move the highlight ()
Click where you want to place it.
--or--
Press the arrow keys ().



To move the insertion point () or highlight ()
Click where you want to place the insertion point or highlight.
--or--
Press the arrow keys ().



To move the insertion point ()
Click where you want to place the insertion point.
--or--
Press the arrow keys ().



To move the insertion point () in the formula bar
Click where you want to place the insertion point.
--or--
To move to the                     Press  
Right one character
Left one character
Beginning of the entry HOME
End of the entry END

To highlight more than one character, drag the mouse pointer over the characters or hold down SHIFT and press   
or    until you highlight the characters you want.



To move to a record
In the lower-left corner of your form, click the buttons until the record you want is displayed.

--or--
1 From the Select menu, choose Find.
2 In the Find What box, type a word or phrase you want Works to search for.
3 Under Match, choose Find Next.
4 Choose OK.

Works moves to the next record that contains a match.    To repeat the search, press F7.



To move to an empty record
In form view, click the Last Record button (located in the lower-left corner of your form).

--or--
In list view, click the down scroll arrow () until the empty record at the end of your database is displayed.



To move to the first record
In the lower-left corner of your form, click the First Record button.

--or--
Press CTRL+HOME.



To move to the first record

--or--
Press CTRL+HOME.



To open a database file
1 From the File menu, choose Open Existing File.
2 Under File Name, double-click the name of the file you want to open.

Note:    Database files have the extension .WDB.
If you can't see all of the file names, click the up or down arrow.
If the file is located in a different directory, double-click the directory then choose the file.



To open or switch to a file
To open a file
1 From the File menu, choose Open Existing File.
2 Under File Name, double-click the name of the file you want to open.

If you can't see all of the file names, click the up or down arrow.
If the file is located in a different directory, double-click the directory and then choose the file.

To switch to a file
Click the file or choose its name from the Window menu.



To open the application and file
1 From the Windows menu in Program Manager, choose Main.
2 Double-click the File Manager.

3 Double-click the directory window that contains the file you want to open, for example, the Microsoft Excel 
directory window.

4 Double-click the name of the file you want to open, for example, expenses.xls.



To switch to list view
On the Toolbar, click the List View button.

--or--
From the View Menu, choose List.

To switch between form and list view, press F9.



To switch to query view
On the Toolbar, click the Query View button.

--or--
From the View Menu, choose Query.



To check that protection is turned off
1 Click the Options menu.
2 If protection is turned off, there will be no check mark next to Protect Data.
3 If you see a check mark next to Protect Data, click Protect Data to turn protection off.



Header and footer codes
When you create a header or footer, you can use codes to change the alignment of text or to insert page numbers, 
the filename, or the current date or time.

To                                                 Type  
Print the page number &p
Print the date in short format &d
Print the date in long format &n
Print the time &t
Print the filename &f
Left-align text &l
Center text &c
Right-align text &r
Print & (ampersand) &&
You can use codes together with text, and include as many codes as you want in a single header or footer.    For 
example, to create a header or footer like this...
Budget Page 1 04/02/91
...type &lBudget&cPage &p&r&d



File
A named collection of information stored on a disk; it usually contains either data or a program.



Query instructions
Entries in query view that specify information you want to match in the records displayed by the query.    When you 
choose the View Query command, Works displays your form with each field blank.    You can type query instructions 
in any or all of the fields.    For example, you can use a query to display a list of those items purchased between May
and August of last year that are in Warehouse 10 and have a selling price between $20 and $40.



Pane
In list view, you can drag the split bars to divide the window into sections called panes.




